Upgrade to 2021.7.3 - grpcio<2.0dev,>=1.38.1'

Config checker coming up with:

Testing configuration at /tmp/config
Fatal error while loading config: (grpcio 1.31.0 (/usr/local/lib/python3.9/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})
Failed config
  General Errors: 
    - (grpcio 1.31.0 (/usr/local/lib/python3.9/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})

Currently on 2021.6.2 image

I’m not using Google Cloud, though do have google_translate for TTS (used hardly ever). Assuming not a big issue to upgrade, but new error so figured I’d throw it out there.

Thx in advance!

Bueller… Bueller…?

I’m having a similar issue when using the upgrade configuration checker. I use Google Cloud for integration with Nest.

[15:28:40] ERROR: The configuration check did not pass!
[15:28:40] ERROR: See the output below for more details.
Testing configuration at /tmp/config
Fatal error while loading config: (grpcio 1.31.0 (/usr/local/lib/python3.9/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})
Failed config
  General Errors: 
    - (grpcio 1.31.0 (/usr/local/lib/python3.9/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})

Successful config (partial)

Currently on core-2021.7.2, running on Home Assistant OS 6.1 on an RPi4.

I’m seeing this as well… I have travis-ci setup, and attempting a check for lastest HA 2021.7.4 gets me the same output:

INFO:homeassistant.util.package:Attempting install of scapy==2.4.5
INFO:homeassistant.util.package:Attempting install of aiodiscover==1.4.2
Fatal error while loading config: (grpcio 1.31.0 (/home/travis/virtualenv/python3.8.7/lib/python3.8/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})
Failed config
  General Errors: 
    - (grpcio 1.31.0 (/home/travis/virtualenv/python3.8.7/lib/python3.8/site-packages), Requirement.parse('grpcio<2.0dev,>=1.38.1'), {'google-cloud-pubsub'})
Successful config (partial)
The command "hass -c . --script check_config" exited with 1.

I tried installing grpcio 1.38.1, and 1.39.0 but get the following for both:

INFO:homeassistant.util.package:Attempting install of ha-ffmpeg==3.0.2
Fatal error while loading config: [Errno 2] No such file or directory: '/home/travis/virtualenv/python3.8.7/lib/python3.8/site-packages/grpcio-1.38.1.dist-info/METADATA'
Failed config
  General Errors: 
    - [Errno 2] No such file or directory: '/home/travis/virtualenv/python3.8.7/lib/python3.8/site-packages/grpcio-1.38.1.dist-info/METADATA'
Successful config (partial)
The command "hass -c . --script check_config" exited with 1.

Thinking it is related to this: Pin gRPC to 1.31.0

If the version is pinned to 1.31.0, but google-cloud-pubsub requires >= 1.38.1, even if you install a newer version home assistant downgrades it back to 1.31.0.

Which in turn looks like it is related to google-cloud-pubsub now requiring 1.38.1 to prevent a crash that was being encountered on M1 Macs: require grpcio >= 1.38.1 to prevent a possible crash

I submitted this issue on github for the problem.