Home Assistant Community

Upgrade to 91.2 Failed with pycryptodome<3.4.0 >=3.3.1

hassbian
Tags: #<Tag:0x00007fcf4f835538>
#1

In case someone else experience the same problem.

Upgrade failed from 90.1 to 91.2.

Python - jose - cryptodome 1.3.2 has requirement pycryptodome <3.4.0,>=3.3.1…
I had 3.8.1

Had to do pip3 uninstall pycryptodome and pip3 install pychryptodome==3.3.1 from “hapyshell via hashell”

Did a reinstall of home assistant again and then it started normally.