Upgraded Pi (An1) from 19 to 20 and killed AsusWRT (help)

16-05-26 15:19:42 homeassistant.components.device_tracker: Error setting up platform asuswrt
Traceback (most recent call last):
File “/home/hass/deps/pexpect/spawnbase.py”, line 144, in read_nonblocking
s = os.read(self.child_fd, size)
OSError: [Errno 5] Input/output error

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/hass/deps/pexpect/expect.py”, line 97, in expect_loop
incoming = spawn.read_nonblocking(spawn.maxread, timeout)
File “/home/hass/deps/pexpect/pty_spawn.py”, line 455, in read_nonblocking
return super(spawn, self).read_nonblocking(size)
File “/home/hass/deps/pexpect/spawnbase.py”, line 149, in read_nonblocking
raise EOF(‘End Of File (EOF). Exception style platform.’)
pexpect.exceptions.EOF: End Of File (EOF). Exception style platform.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/device_tracker/init.py”, line 119, in setup_platform
scanner = platform.get_scanner(hass, {DOMAIN: p_config})
File “/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/device_tracker/asuswrt.py”, line 48, in get_scanner
scanner = AsusWrtDeviceScanner(config[DOMAIN])
File “/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/device_tracker/asuswrt.py”, line 68, in init
data = self.get_asuswrt_data()
File “/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/device_tracker/asuswrt.py”, line 153, in get_asuswrt_data
neighbors, leases_result = self.ssh_connection()
File “/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/device_tracker/asuswrt.py”, line 112, in ssh_connection
ssh.login(self.host, self.username, self.password)
File “/home/hass/deps/pexpect/pxssh.py”, line 280, in login
i = self.expect(["(?i)are you sure you want to continue connecting", original_prompt, “(?i)(?:password)|(?:passphrase for key)”, “(?i)permission denied”, “(?i)terminal type”, TIMEOUT, “(?i)connection closed by remote host”], timeout=login_timeout)
File “/home/hass/deps/pexpect/spawnbase.py”, line 315, in expect
timeout, searchwindowsize, async)
File “/home/hass/deps/pexpect/spawnbase.py”, line 339, in expect_list
return exp.expect_loop(timeout)
File “/home/hass/deps/pexpect/expect.py”, line 102, in expect_loop
return self.eof(e)
File “/home/hass/deps/pexpect/expect.py”, line 49, in eof
raise EOF(msg)
pexpect.exceptions.EOF: End Of File (EOF). Exception style platform.
<pexpect.pxssh.pxssh object at 0x76484850>
command: /usr/bin/ssh
args: [’/usr/bin/ssh’, ‘-q’, ‘-l’, ‘admin’, ‘’]
searcher: None
buffer (last 100 chars): b’’
before (last 100 chars): b’’
after: <class ‘pexpect.exceptions.EOF’>
match: None
match_index: None
exitstatus: None
flag_eof: True
pid: 873
child_fd: 7
closed: False
timeout: 30
delimiter: <class ‘pexpect.exceptions.EOF’>
logfile: None
logfile_read: None
logfile_send: None
maxread: 2000
ignorecase: False
searchwindowsize: None
delaybeforesend: 0.05
delayafterclose: 0.1
delayafterterminate: 0.1
16-05-26 15:19:44 homeassistant.components.recorder: Found unfinished sessions

Thanks in Advance,

You don’t seem to have ssh enabled on your router. You can either enable ssh, or if you prefer to continue using telnet, you can specify telnet as the protocol in your config.

protocol: telnet


So I updated my tracker from the example I sourced here to include that line & I’m back in business. Thank you Froz!

platform: asuswrt
username: *****
password: *****
protocol: telnet
track_new_devices: yes

Seconds between each scan for new devices (default: 12)

interval_seconds: 61

Seconds to wait till marking someone as not home after not being seen

(default: 180)

consider_home: 180