Uploaded file is too large

I’m trying to upload some audio files to be able to play using the media player. I’m trying to use the “Add Media” option under the Media → Manage(Media Management). Seems like there is an upload maximum in the Lovelace UI as I just get the error “Uploaded file is too large” when trying to upload a 1.1MB or 3MB file. Is there some place to change the upload maximum size?

5 Likes

So I started to do some Googling and came across this GitHub Issue that clued me further into the real problem. I’m using the Nginx SSL Proxy add-on and that’s how I access my HA instance locally. Reading about ingress upload issues I decided to load up my HA instance using the standard HTTP port 8123 and then I was able to upload the files with no problem. So it would seem that the issues is the Nginx SSL Proxy. I’m going to have to dig into that.

4 Likes

Getting the same error on any upload. But while connected on local server on standard port http 8123.
Did you find any details on root cause?

Hmm, I didn’t have a problem when not using the local port without going through Nginx Proxy.

Same problem on local HA, did you find solutions for that?

I get the same error when trying to upload larger files; it doesn’t matter if I use a local http or my DuckDNS https URL. Anything over 10,544,323 bytes fails.

For a work-around I just manually copied the mp3 files to the \192.168.0.20\media share created by the Samba Share Add-On.

1 Like

I think this is the only way now, thank you for the idea :bulb:

Is there any solution to upload large files?

I cannot upload even mp3 file of 10.4 MB.
2023.9.2.
Same “Upload failed: Uploaded file is too large”.

Update: seems that a reason of this error was that I have not configured “media_dirs” properly.
In fact - I have not configured it at all, it was a default config.
In “Media” this is what I saw.
And yet the “Add media” button was made available for me - and then I am getting an error with an absolutely unrelated description.

Imho, this whole “media” functionality is rather untested…

I am facing the same issue with Nginx SSL Proxy add-on + duckdns https url for remote access. No issues when on local network. Currently limited to max upload size of 1MB. Has anyone found a solution?

Same here using the web interface on the local network. :persevere:
It’s been ongoing for such a long time…
I have resorted to adding the Samba Add-On. It’s unfortunate.

maybe try scp.

Anyone managed to resolve this issue ?
I can’t upload even 30MB file neither directly or via Nginx proxy.

Have you tried scp?

Had the same issue.
Another way would be to drag and drop to the vs code server and then move the file to /media.

Using NGINX as a reverse proxy the solution was adding

 client_max_body_size 1G;

to my server config.

Ran into this myself. I found out if you upload a file via the web interface, it will go directly into the “media” folder, which will show up if you connect to your Home Assistant server via SMB for example.

Size limit doesn’t seem to apply when adding files this way. The web interface wouldn’t even let me upload a 12 MB file, but after adding it through Windows Explorer, it shows up and will play fine.