USB Boot on Raspberry Pi 4

@Jpsy did you try boot using usb2? it boots lightning fast for me. First boot obviously takes a few minutes (depending on internet connection speed) because of downloading docker images.

@Recte what’s wrong with bootrom from 3.9? is it something widely kniwn or it’s just issues with your config?

I don’t know exactly what is wrong with it, but my SSD dit got power at boot time but had no activity with the latest eeprom. In other words, it was not accessible.

@maxym: This is astonishing! I can fully confirm your observation: Booting with the SSD connected through USB 2.0 takes about 2 minutes. Booting connected through USB 3 takes forever!
I am not happy though to run the SSD over USB 2 as the transfer rate of USB 3 is about 15 times highter. But I did some tests and HA seems to be very responsive. So I will stay with USB 2 until the problem is fixed. Thanks for that information!

@Recte: I cannot confirm this. My SSD has no power problems with EEPROM firmware 2020-09-03 (Crucial BX500 + Sabrent USB 3 adaptor).

I got my raspberry pi 4 boot from usb stick with HassOS 5.2 beta and everything worked fine less thr Bluetooth sensors, i can get readings from the sensors, but only if i move them really really close to the Pi… And then i went back to the sd card with hassos 4.3 and Bluetooth is working again has it should. Is this a know problem? Or there’s something i can do about it?

@JorgeMaTeixeira yes, this is a known interference!
Unfortunately USB 3.0 signals can interfere with radio transmissions in the 2.4 GHz band. This may affect Bluetooth, Wifi and Zigbee communication.

What you can try to do is using better cables for USB 3.0 and/or try to move any communicating adaptors (like Zigbee sticks) as far away as possible from the Pi and its USB 3 ports using a USB male/female cable. I would also connect such sticks to the USB 2 ports to limit interference of the stick with the signal on its own cable (although the 3.0 ports should switch back to USB 2 protocol on such sticks).

I finally found that the long boot times in my setup were a result of the JMicron JMS583 bridge chip in my SATA adapter. After updating the adapter firmware booting times on USB 3.0 are down to 3 minutes. Read the full story here:

I have tried to follow the steps, but didn’t managed to boot from USB. I had mmc0 timeouts only

Did you try one of the USB 2 ports?

I have tried USB 3.0 and USB 2.0 port as well. I’m using pny Elite Portable SSD with USB 3.0

I am using a Crucial BX500 SSD with a Sabrent SATA to USB 3 adapter (EC-SSHD) that is updated to the latest JMicron firmware. Works fine for me.

Like I wrote: ‘but my SSD dit got power at boot time but had no activity with the latest eeprom’

So somehow it was not accessible. I use a Philips FM24SS020P connected straight to the USB3 port.

@peetereczek: Have you tried these steps too? USB Boot on Raspberry Pi 4

Pi can boot from USB, I have flashed Rapsbian on USB Pendrive 16GB and it boots from it. It does not on with my SSD… So It seems that it’s SSD issue, or HassOS. I need to try with bigger USB Pendrive, maybe HassOS will boot from 64GB Pendrive

For what it’s worth, @Jpsy his SSD boots with EEPROM firmware 2020-09-03, mine doesn’t.
Mine boots with v2020.07.16-138a1. For me it was worth the try.

I haven’t investigated the difference between, the versions (yet), but am happy with the fact that I have a (working) solution for the problems that made me wanna move to the SSD.

I have a Pi4 4Gb, Simplecom SATA dock (JMICRON JMS567 bridge) and Samsung 860 EVO SSD

It works well under raspbian 5.4.51-v7l+ Bootloader Sep 3 2020 after I added usb-storage.quirks=152d:0578:u to cmdline.txt

I have had no success with this configuration in trying to USB boot hassos_rpi4-4.13.img

Does the hassos kernel respect the usb-storage.quarks command?

Booting from SD Card
Starting start4.elf @ 0xfec00200 partition 0

U-Boot 2020.01 (Sep 09 2020 - 01:54:54 +0000)

DRAM: 3.9 GiB
RPI 4 Model B (0xc03112)
MMC: [email protected]: 1, [email protected]: 0
In: serial
Out: serial
Err: serial
Net: Net Initialization Skipped

Booting from SSD
Starting start4.elf @ 0xfeb00200 partition 0

U-Boot 2020.01 (Sep 09 2020 - 01:54:54 +0000)

DRAM: 3.9 GiB

Did anyone tested whether the 64bit version works with Zwave, Zigbee etc when booting from SSD? It tried but it seemed to fail…

Zigbee works fine. using Zigbee2mqtt addon. 10+ sensors.

For as far as I know, you need OS version 5.x for SSD boot, but correct me if I am wrong.

I have no issues other than USB3 interference which can be easily solved by:

  1. using an USB extension cable for the Conbee II stick
  2. using USB2 only

It basically has nothing to do with the SSD boot itself.

Zwave works fine booting on SSD.

It works fine now :slight_smile: using an ssd is a relief :slight_smile:

1 Like