USB SSD will not boot on Pi 4

I have made the necessary changes (i think) to make my Pi 4 boot from USB using this tutorial https://www.jeffgeerling.com/blog/2020/im-booting-my-raspberry-pi-4-usb-ssd
When inserting my SD card in a SD to USB converter it boots fine, but when using my SSD drive or a USB memory stick instead it will not boot. I have made a clone from my SD to a SSD drive with Win32 disk imager.
What am I missing?

It depends what version of hassio you are running on the SD.
If you are running a supervised version with RaspberryPi OS, it should work
If using the development build of raspberry pi 4 64 bit image it will work.
All other versions will not work (release hassio image, beta 32 bit image)

Not sure why it works with the SD card via usb converter. That is interesting…

I struggled with this for a while this week too. I gave up as development hassio 64 bit and supervised hassio used too much ram and my home assistant kept crashing. I only have a 1 GB Pi4. Need to upgrade before I switch from the SD card.

If you have a 2G or higher pi, I would recommend saving a snapshot, starting fresh, then restore snapshot. I had an issue directly restoring snapshot, I had to setup SMB add-on, then load the snapshot and restore. Good luck

Development build (listed on top of releases)

Instructions on supervised hassio:

I am not running Hassio and still running 0.103.6 on a 4Gb Pi 4.
Must the SSD be prepared for booting or something?

I had problems booting until I found this solution: https://www.raspberrypi.org/forums/viewtopic.php?t=245931

unfortuneately this didn´t help.

What does it say under: Supervisor -> System -> Host System?

How is your home assistant installed - Supervised on Raspberry PI or Home Assistant OS?

I just installed the Core version following this

Hmm, that should work if you used a recent Raspberry PI OS. If it is an old PI OS, it may not work. Since you are on 0.103.6, my guess is your PI OS is quite old.

To diagnose your SSD works, install latest stock Raspberry PI OS Lite or the hassio beta 64 bit image to the SSD and see if it boots.

If you are not using your PI for anything else, I would stronly recommend trying the supervised version or, better yet, the hassio beta 64 bit image. It is much easier to keep up to date, the virtualenv is such a pain (probably why you are so far behind).

I updated OS before this and am now on Debian Buster V10. I guess that should be ok.
I will try to install the latest OS on the SSD directly and see if that changes anything.
I just don´t understand why it works when booting from the SD inserted in a USB converter.

Any updates about HAssio 32Bits on SSD?
I’m running Rasp4+SSD+HAssio64Bits. Everything is working, but buggy.
Random command delays and sometimes the Webserver service(HAssio UI) just doesn’t load on first attempts.

It worked for me when I finally flashed the SSD with the newest Raspberry Pi OS and then installed HA.
Prior to that I tried with the older version from the SD card with HA installed.
It runs quite stable.

1 Like

Hi @jeppper .
Three years and I still get confused with HassOS/HAssio/etc… :thinking:
When you say “Raspberry Pi OS and then installed HA” you are not talking about the image (Raspberry Pi 4 Model B (1 GB, 2 GB and 4 GB model) 32-bit) burned with Etcher directly on the SSD no, right?

You install Raspberry Pi OS on an SD card just so that you can update FW Rpi4. Install HassOS 5.5 64 Gb on the SSD and run without SD card.
However, it depends on the supported SATA SSD adapter.

I use the Lite version from https://www.raspberrypi.org/software/operating-systems/
I just flash the SD card and then update the PI as @pepe59 writes.
Afterwards I flashed the same image to the SSD and installed the HA core version.
Then it worked