Use for that old ADT Camera

I got my hands on an older ADT Pulse camera (RC8025B) and decided it would be a fun little project to integrate into HA. It’s not the greatest camera (640x480 BW), but maybe others can leverage this for other models.

So, let’s begin…
On the back of the camera is a black button. Reset the camera to default by pressing and holding it until the LED flashes. Unplug the power to the camera and then plug it back in. Give it a few seconds to boot up. Now, the back of the camera has an RJ45, so plug it into a router, along with a PC. Using whatever router utilities you have, get the IP address of the camera. For this, let’s assume it’s 1.2.3.4.

Now go back into your router and use parental controls and enable parental controls/blocking to/from 1.2.3.4. This is to prevent it from trying to reconnect to ADT and pulling their settings back into the camera. This blocking will need to be permanent, so keep this in mind if you change the IP at any point.

Now onto the camera itself…We need to tell the device to enable us to log into it. Using your browser, go to:

http://1.2.3.4/adm/enable_ui.cgi.

It should respond back with a simple. ‘OK’ webpage. Now go to:

http://1.2.3.4/

with the username ‘administrator’ and a blank password. You will be able to choose to view the stream or go to administration. You can view the stream to confirm it works, but we really need to go to administration.

Hopefully, that enable url is a one time thing for you. But, if you should ever have problems getting in directly, just reuse the enable url and you should be good.

Pretty basic interface, but there are some things you need to change. Listed below are the things you need to do. Anything not mentioned is optional and up to you. Make sure you click the ‘save’ button before you go to the next screen.

Setup>System (optional):
If you are going to keep the time and date stuff accurate, and I don’t see a reason to, at least set it to a different NTP server. Use time.nist.gov.

Setup>Network:
I encourage a static IP. If you go dynamic and it ever gets a new IP, it will try to phone home. If it is successful, all of these settings will likely be wiped. Save yourself the trouble later. If you change it, don’t forget to update the parental controls/blocking on the new IP.

Setup>Wireless (wireless is only 2.4GHz):
Network Type: Infrastructure
Enter your SSID and WiFi password (shared key).

Setup>DDNS:
disable

Video>Streaming:
You only need one, so disable the second and third. For the one, use the following settings:
Video Format: MJPEG
Resolution: 640x480
Fixed Quality: Very High
Max Frame Rate: 30

Video > User Database:
To be safe, create an ‘operator’ account and password for your use. After you save it, it takes a few seconds for it to actually appear in the drop down menu.

Administration>Maintenance:
To be safe, change the default password.

Unplug the camera. Remove the Network cable. Power it back on. Check your router to make sure it connects over WiFi and put the parental controls/blocking in place, if it has a different IP from before.

With the camera settings complete, it’s time to make it visible in HA. We will need to edit the configuration.yaml file. If you are not sure how, I suggest installing the File Editor add-on. Add the following to the bottom of the file:

Camera:
  - platform: mjpeg
    name: “Your Camera Name”
    #still_image_url: http://1.2.3.4/img/snapshot.cgi
    mjpeg_url: http://1.2.3.4/img/video.mjpeg

Yes, I commented out the still image line. If you leave it in, it will not do live video. I just keep in case I ever want it.

If you now go to the Configuration>Devices & Services>Entities, you should see the camera there. If you tap into it, you will get a message that it doesn’t have a unique id. Kinda a bummer, but not a big deal. Still fully usable.

With that, you should now be able to go to your dashboard and add a picture entity card (not just an entity card). You should be able to find the camera by the name you assigned it. Set the camera view to ‘live’. When you leave dashboard edit mode, it may freeze the image. Just reload the page (or app), and it should come back to life.

I have been trying to make it so a single-tap will take a screenshot, but I am not there yet.

Hope this is useful to someone. If not, at least it will be here in case my system ever gets corrupt and I need to start over.

Got an ADT oc835? You can do similar, but it doesn’t look like there is a gui.

Turn on the camera and hold down the WPS button on the back for about 10 seconds. That should reset it. Next, use the WPS or the PIN on the back of the camera to connect it to your wireless network.

Once connected, get the IP address and, using your router, parental control/block access to the camera.

If you just want to pull the stream, the url will be:

http://1.2.3.4/img/video.mjpeg

If you want to play around with settings:

Get a list of setting groups with:

http://1.2.3.4/adm/get_group.cgi

Dig deeper into any of those groups using:

http://1.2.3.4/adm/get_group.cgi?group=GROUPNAME.

Want to set a value, do something similar:

http://1.2.3.4/adm/set_group.cgi?group=GROUPNAME&setting=value.

For example, http://192.1.2.3/adm/set_group.cgi?group=SYSTEM&hostname=Camera001

Most settings are pretty obvious, some have values that are not obvious, like group=AUDIO&audio_mode=1. Not sure what that means.

2 Likes

I have a OC835 camera.
Im unable to login. I already tried all the combinations , including administrator with a blank pw field

It has been a while and I stopped using those cameras some time back. I will still try to help. Can you give us some more information? Were you able to get the camera to connect to your network? If so, do you have the IP address? I don’t need it, just wanting to see how far you got.

@TexasAssistant Thank you so much for this. I have an OC835 from the previous owner’s system, and I was able to get it in HA with the info you provided.

I did want to share a bit of info for anyone else who may come across this (if anyone else is still trying to get these old cameras to work lol). The OC835 that I have does not have a UI available, but everything can be configured using the web get/set endpoints. My actual problem: my main router doesn’t support WPS - but fear not! If you have an old router lying around, you can trick the camera.

  1. Set the OLD router with WPS with an SSID that is different from the NEW router, but with the same password on both routers
  2. Use the WPS function to connect the camera
  3. Configure your settings on the camera
  4. Once you’re ready to put it on your actual network, simply change the SSID (/adm/set_group.cgi?group=WIRELESS&wlan_essid=MainNetworkSSID)
  5. It should change over pretty quickly. Once it does, connect to your main network on the computer/device you are using to configure everything

From this point, you should be able to get it in HA pretty easily using the MJPEG IP Camera integration. I did this instead of editing the configuration.yaml

I was also able to change the settings to 720p. Strangely, my camera was set to preset #3, so I had to update all the settings for the quality ending in “3”. Anyway, just thought I would add to the discussion!

EDIT: And to get rid of that pesky ADT logo: /adm/set_group.cgi?group=VIDEO&bmp_overlay=0