Use lets encrypt with own domain (a record)

How can I make let’s encrypt work with my own domain?

I’ve installed the add on, and set the variables point to (but then with my actual domain).

When I do this, I can’t access home assistant anyway anymore.

I forward 443 on my router to 8123. Do I have to do any additional setting?