Use the app with local IP

Hi, I want to use the Android app on my tablet, but the app doesn’t discover my HA instance automatically.
When I do this manually (using https://192.168.0.x:8123), I just see a white screen. When I close the app and reopen, I go back to the start screen searching for a HA instance.

I can’t use my duckdns address locally because when I try using it, my ISP router craches and reboots.

Any ideas?
Thanks!

I had this issue using the HassKit app. As it turned out my tablet is very behind the times (nexus 7) and the webview was so out of date it couldn’t display the login page. Once I updated system webview it worked. I was able to login and use the app.

Not saying this is your issue, but it sounds familiar!

It’s a new tablet, Galaxy Tab a 10.5 fully updated.
When I open HA in chrome it works perfect (only the ssl error).

Instead of using SSL directly on HA, use a reverse proxy that handles your SSL, and then you can use the http version of your internal IP. The app doesn’t know how to deal with unknown/untrusted certs.

Do you have some guidelines on how I can do this? :slight_smile:

Thanks! Worked great!

Tyied using it a fex months ago and it didn’t work for me. Now it looks like it does exactly what I need!

I’m also unable to connect in the HA Android app on my local network after I installed DuckDNS with Let’s Encrypt.
So I installed Nginx Proxy Manager, but how do I configure this? Do I have to add a proxy host or a redirectio host? And how do I fill in the form?

port forward 443 to 443
provide your duckdns address to the domain property.
443/tcp should be set to 443

1 Like

I managed to get it working. Thanks!