Use ZigBee group for IKEA components in ZHA

Dear all,

I’m trying to establish a Zigbee group allowing to directly control three Tradfri lights via a Styrbar 4-button remote control.

I successfully established the group “Deckenlampe Schlafzimmer” of three lights. Automatically, two other members (representing the coordinator?) were included as well:

Note, also an Entity called “Silicon Labs EZSP Deckenlampe Schlafzimmer” (this is composed by my coordinator chipset plus the group name) was automatically created. It contains the options to control all light properties. I would say this seems to represent the Zigbee group in HA?

I then connected the remote control to the group:

I clicked “Gruppe binden” and after some seconds, a green button confirmed this worked.

Still, the lamps do not react to the remote control.

Did I choose the right procedure? And will I be able to also vary color temperature and brightness via a direct connection using a ZigBee group?


Is there some diagnostics I should send?

Grouping in Zigbee simply groups the devices together to minimize commands to them.

What you want to do is BIND the remote to the lights. You can do this through ZHA: Zigbee Home Automation - Home Assistant

Only if the remote supports that. Most remotes do not, so you’d probably have to create automations to change those parameters.

@code-in-progress: Thank you!

I think I tried the binding: I first created the group and then - in the second screenshot - I bound the remote to the group.

I forgot to mention that I also have single Tradfri lights which I successfully bound to Styrbar remotes. So the remotes seem to be able to do that at least for single devices.

Another thing: Using the IKEA Dirigera hub, binding seems to be the standard way of including devices. I have to move the remote closely to the device I want to control during inclusion process. On the IKEA hub, this also works for multiple lights (I assume creating ZigBee groups in the background, in this case)?

Might depend on the firmware → zigbee2mqtt documentation

Note that the remote loses the capability to bind to a group in the latest firmware.

Thanks a lot, that might be the issue.

Still, some people seem to be able to link it to a group?!?
Styrbar binding problem : r/Zigbee2MQTT (

This has been reported few months ago. If I got it right, if this was a firmware issue, both ZHA and Z2M should fail. Correct?

Correct; As I said, depends on the firmware version.