Username already exist

Hi all,
I’ve erased an user by accident, then I tried to re-create the user but I got the message “user already exist”. do you know I could fix it?

1 Like

I have exactly the same problem :frowning:

Did nothing special just a simple deleting via GUI.
User is not visible, neither used anywhere, as user was just created recently.

Already restarted HA, did not help.

Seems like deleting a user does not fully delete it ?

That would be bad. :frowning:

(running the latest version 2022.3.2)

Hi Vaemd,

Ever solve this one?

Cheers,

Jarrod.

Same problem, Had a MQTT login in config for mosquito broker. Recent update broke my MQTT so I reinstalled. Now I can’t put the login in config because MQTT can’t restart says already has an instance in docker.
Now mqtt can use a user so, I tried to create using same name as my original config file but, it says username exists. Nowhere to be found. All my tasmota devices won’t work.

Just been hit with this on a new build, has anyone found a solution ??

Have the same/similar issue. I deleted a user but HA didn’t deleted it correctly. I can use the user completely normall but it isn’t shown in Settings>User. And I can’t make a new user with this Name.

I guess its a buck and the HA can only do something about it.

be super careful about not making any changes but…

what’s in this file: /config/.storage/person

?

is the person missing there?