Using mariadb for recorder fails after upgrading to stretch


After upgrading from Jessie to Stretch, I haven’t been able to get my recorder (and things that depend on recorder, like history and logbook) to work. I have been using mariadb in Jessie, and as far as I could gather, this is what Stretch now uses as the default.

In my log, I get:

2017-10-18 18:13:32 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: cannot open shared object file: No such file or directory (retrying in 3 seconds)

I’ve tried the best “fix” I could think of; just making a symlink:

sudo ln -s /usr/lib/arm-linux-gnueabihf/ /usr/lib/arm-linux-gnueabihf/

But then I get an error:

2017-10-18 18:19:06 ERROR (Recorder) [homeassistant.components.recorder] Error during connection setup: /usr/lib/arm-linux-gnueabihf/ version `libmysqlclient_18' not found (required by /srv/homeassistant/lib/python3.5/site-packages/ (retrying in 3 seconds)

Has anyone else upgraded from Jessie to Stretch while using mariadb, and have an idea about what I can do?

If this matters, I actually completely uninstalled and re-installed mysql, mariadb and databases, and re-installed it, since I was getting other errors about paths that didn’t make sense to me to begin with, and found someone claiming this as a potential solution. Also, I am using an USB stick for the database, but here I haven’t changed anything (it still automounts, etc.)


I have the same problem after burning the latest Hassbian. Did you find a solution?

Nope, sorry. I’ve started the (more laborious than I anticipated) process of doing a clean install on raspbian stretch lite, and setting it up again. With a backup of my last working (Jessie Lite, home assistant 0.60)!.

I’m not sure, but during the research I found that on stretch, mariadb is used as default, so maybe that has something to do with it?