Using phone device_tracker for GPS, but not home detection

Hi!

I currently have the problem that I want to use Wifi as my main (only) home detection while still having my phone set up as a device_tracker to be able to track my location on the map.

For the wifi home detection I have created a binary sensor based on the connection of my phone to the home wifi. This works really well and is a lot more accurate than using my phones GPS (as I’m often close to my home, but not actually in the house).

Now if I connect both the binary sensor and the phone to my person in HA, the phones home state overwrites the binary sensor. I think this would be fixable by setting the binary sensor to source_type = router, but I can’t figure out how to do this - is it possible? And would that mean that if this tracker is set to “home” and the phone “gps” tracker changes to not_home, the person remains set to home?
If I set only the binary sensor to my person the home-tracking works, but my location is not displayed on the map.

Is it possible to still use the phones GPS to my person, without it being used for home detection? My workaround that I would try next would be setting up a new “person” being only my phone, so at least that one is showing on the map.

FYI, this is how I have set up the binary_sensor in combinatiuon with the compoisite tracker currently:

template:
  - binary_sensor:
      - name: "Person WLAN Zuhause"
        delay_on:
          seconds: 30
        delay_off:
          seconds: 30
        state: >
          {{ is_state('sensor.personpixel_wifi_connection', 'Wifi Name') }}

composite:
  trackers:
  - name: person_home_or_away
    time_as: device_or_local
    require_movement: true
    entity_id:
      - entity: binary_sensor.person_wlan_zuhause
        all_states: true