Using RTSP from Xiaomi camera with MiHome cloud working. Testing needed

Tags: #<Tag:0x00007f3f17f7da70>

I made a tool to enable the Xiaomi Camera Gateway to work with RTSP without flashing a alternate firmware and therefore keeping MiHome cloud functionality working. Using the camera with Home Assistant is then fairly simple.

Seems to work fine with the camera I have (lumi.camera.aq1) but have not tested it on other xiaomi cameras.

Is there anyone here that owns a different Xiaomi P2P camera willing to test and report?

2 Likes

how the same things can be done in Android OS? i mean forwarding video from xiaomi camera to RTSP by android.

I have 6 new cameras still in the box, will give it a try next week and update

Failed during build:
Running aclocal …
Running autoheader…
Running automake --foreign …
Running autoconf …
Running ./configure …
checking build system type… x86_64-pc-linux-gnu
checking host system type… x86_64-pc-linux-gnu
checking target system type… x86_64-pc-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking whether make supports nested variables… yes
checking whether make supports nested variables… (cached) yes
checking for gcc… gcc
checking whether the C compiler works… yes
checking for C compiler default output file name… a.out
checking for suffix of executables…
checking whether we are cross compiling… no
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking whether gcc understands -c and -o together… yes
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking how to run the C preprocessor… gcc -E
checking for g++… g++
checking whether we are using the GNU C++ compiler… yes
checking whether g++ accepts -g… yes
checking dependency style of g++… gcc3
./configure: line 4242: syntax error near unexpected token JSON_C,json-c' ./configure: line 4242:PKG_CHECK_MODULES(JSON_C,json-c)’

hi
found that this solution worked for me (vm with ubuntu)

indicate that the macro PKG_CHECK_MODULES might be missing on your system.
This macro is part of pkg-config which you can install via apt-get install pkg-config .

Anyone using this with lumi.camera.aq1 I have integrated it but rtsp stream is very laggy and mainly only shows stills?

I use it on the Ubuntu host system and it is very smooth. Before that I tried it from docker container but it was terrible.

Thanks Ill give that a shot I was running it on a dedicated Pi 3 but should just move it over to my ubuntu server