Using Tasmota and a nodemcu to control WS2812B Leds

Ive been trying to find a solid, reliable and relatively cheap method of LED lighting, primarily for the kitch cupboards, which wont get used all that often, hence the reluctance to spend big.
And so far, I haven’t been overly successful.
Ive tried a MagicHome Wi-Fi controller…that worked for all of a day or 2, and then the unit just died…seems to be common on these units.
Ive tried a mi-light Wi-Fi RGBW led strip controller, and this works to some extent, but for some reason can only run a pretty short length of strip (powered by 5V)

Anyhoo, I realised that Tasmota can natively control WS2812 leds, correct?
I have a few spare NodeMCUs knocking about, and have mamnaged to flash with Tasmota…can I use these to run an LED strip? If so, does it have to be WS2812B like these?
As far as I can figure out (I have very basic electronics knowledge) the strip needs to be powered by 5V and the data pin hooked upto one of the NodeMCUs GPIO pins?
Can the 5V come from the 5V GPIO on the NodeMCU?

Sorry for the basic questions…

Use ESPhome on the NodeMCU. Very easy. Just feed the strip 5v, 0v and data. The data line comes directly from a pin of your choosing on the NodeMCU.

I briefly had a play with ESPhome via a VM install of Linux, bit wasn’t successful. I can’t seem to find a good comprehensive ‘dummies’ guide.
Would I install it on the same Pi as HA? And I can upload to the node direct via USB hooked to the Pi?

Did you read through this? Also, once installed there is a wizard which you can use to help you through setting up a node.

It’s very easy to install on the same Pi as HA. Are you using HassIO or basic HA? There is a HAssIO add-on for the install. Yes, you can uploda to the node plugged into the Pi via USB. Then if you enable OTA transfers you can do updates / change code without having to plug it in ever again.

Yeah had a read through that. I’ll look through it again.
Maybe it was down to running it in a VM?

I’m running Hassbian

I’m not sure about the whole VM thing… I think Hassbian shouldn’t be an issue itself. So Hassbian is running in the VM, or was that just another machine you tried it on with the VM? You could run it on any linux machine that you have available… another RPi?

No, sorry
Hassbian is running on a Pi, I was just playing with ESPhome on a VM inside windows. I think it was Ubuntu.
I tried installing ESPhome on the same pi as hassbian but kept getting errors so have up.
I’ll have another bash (pun intended :wink:) at some point, failing that I have many pi’s knocking about

You can just use tasmota for WS2812 and you need a 5v power supply with more Amp. But you say that your MagicHome Wi-Fi controller die? I have one for almost 2 years now and 4 more for 6 months and everything works well for me.

Yeah, I think I got a naff unit. I can’t access it at all, tried multiple apps, multiple power cycles. Nothing. Can’t even get it to act as an AP, nor can I reset it.

1 Like

What type of Tasmota module did you use for ws2812 and nodemcu?

Generic module

Have you tried WLED ?

Thanks @n1k5y for your quick response.
I’m trying to make it work without success.
I’ve powered the 40 led string (WS2812B) with 5V 3A and wired the DATA to D4 - GPIO2 of a nodemcu with last version of Tasmota.
light class appears correctly at HA and you can manage it but NO LIGHTS at all…
Any clue of what could be hapenning?

If I’m not mistaken, the ground from the power, esp8266 and the led strip, have to all be connected to each other still.

thanks! i’ll try it.