Using the Ring Alarm Keypad with Home Assistant

With ZWaveJS2MQTT now supporting S2 security, I was able to get the Ring Alarm Keypad working perfectly with Home Assistant. I thought folks might be interested, so I put together a writeup showing how. I hope folks find it useful - let me know if there are any questions or comments.

6 Likes

Your first link on the github page is dead.

What are the thing you are doing, or planning to achieve, using the keypad with HA?

I know home/away/armed/disarmed would be obvious ones, but what do your commands do?
We would not need any Ring base station nor Ring app, right?
What else become possible?

Just curious; I’m looking for ideas.

So, I’ve already got an alarm system set up in HA using Alarmo, with sensors provided by a Konnected module reading the sensors from the old alarm system that was in our house when we bought it.

There was no easy way to convert the old alarm keypad to work with HA, so I wall-mounted a Kindle Fire tablet. But it’s pretty flaky - crashes occasionally, and often doesn’t register touch inputs properly, which is bad when someone’s trying to disarm the alarm.

My goal is just to replace it with something that looks and acts more like a normal alarm keypad, and boost the WAF. This seems like the cleanest solution I’ve found so far.

Weird, all the links are working for me. The first link is just for the product page for the keypad on Ring’s site.

The link seems to redirect to a local page, and I am guessing the device may not be available in nz.

Thanks very much for sharing this. My use case is similar to yours, so I’m happy to have this as a data point.

Great info and how-to for Ring keypad, thanks. Will need blueprint to help integrating with Alarmo or HA native Alarm.

I put together a blueprint for the necessary automations, if you’re still interested.

Will give it a try, thanks!

Been trying the blueprint, the keypad will pick-up the state when set from HA-Alarmo, but will not work the other way. For example, when arming from the keypad, does not transfer to HA-Alarmo. Any ideas? Trouble shooting?

Interesting. What behavior do you see when you hit the Arm Home button, for example? If you look at the automation trace, did it run? If so, which path did it take?

@ImSorryButWho Turns out had to exclude then re-add the keypad for some reason. What is not happening, however (using blueprint) is any signals, voice, or change to the Ring keypad when setting alarm either at the keypad or within HA. The state is definitely changing when arming from the keypad, however no countdown, no lighting of state on the keypad etc. Figure may be an issue with zwave_js.set_value?

Here is the error on Trace: Indeed seems unable to set the value on the keypad…

Stopped because an error was encountered at November 21, 2021, 9:19:39 AM (runtime: 0.43 seconds)

Value 43-135-0-2-1 not found on node Node(node_id=43)

That means that ZWaveJS doesn’t think the keypad has the Indicator command class. Try re-interviewing the node (under the advanced button in the ZwaveJS2MQTT UI), and watching the debug log for errors.

Interviewing a node can be pretty bandwidth intensive, so it might help to move it closer to your controller when you interview it, then run a heal when it’s working and you’ve put it back in it’s normal spot.

Works like a charm using the manual alarm control panel and some automations, thank you very much for this ! :slight_smile:

1 Like

Same problem here, how do we set the device into exclusion mode?

I’d try manually reinterviewing the node first. If that doesn’t work, stick a pin in the hole on the back to put it in exclusion mode.

I’ve reinterviewed and now I can’t see the battery level, so i’m going to assume it’s not worked?

Try bringing the keypad close to the controller when you’re doing the interview. This device has the longest interview of any ZWave device I’ve ever used, and it sounds like you’re dropping some packets. A better signal from proximity might help.

The rest hole is on the back, just below the channel for the power cord, on the same side as the label.

1 Like

Thanks, the hole looked like an LED at first sight.

I removed and re-added, this time keeping the device alive by pressing random keys during the interview.

All working now thanks! :slight_smile: