Using unifi addon in combination with DuckDns

Today I did buy an Unfi router setup to replace my current router.
Everything worked fine and is up and running.

Now I do like to use the unifi addon controller but I’m not able to get it running.
Installing is fine but when I open the WEBUI it gives an error that Duckdns is refusing acces.

I did use the standard configuration in the unifi addon.

ssl: false
certfile: fullchain.pem
keyfile: privkey.pem

What to do to get this addon running?
In de user manual of Frenck it says

 7. Change the  `Controller Hostname/IP`  to match the IP or hostname of the device running Home Assistant.
8. Check the box  `Override inform host with controller hostname/IP` .
9. Hit the "Apply Changes" button to activate the settings.

I can do that in my controller installed at windows, but I’m afraid that I cannot enter the controller anymore from my PC and not from HA.
I also don’t know exactly what to fill in “Controller hostname/IP”:

The ip of my RPI or the duckdns login or?

The Log looks fine?

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] executing... 
----------------------------------------------------------- Add-on: UniFi Controller
 Manage your UniFi network using a web browser
 Add-on version: 0.14.1
 There is an update available for this add-on!
 Latest add-on version: null
 Please consider upgrading as soon as possible.
 System: HassOS 3.13  (aarch64 / raspberrypi4-64)
 Home Assistant Core: 0.108.5
 Home Assistant Supervisor: 217
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[21:16:38] INFO: Starting the UniFi Controller...

Any advice please?

I did get it running by local login (not using DuckDNS but the local IP) and the port changed from 8443 to 443.

Because of this I can only login locally to my Unifi controller.

I still like to find out to login in the controller using DuckDNS.
Any help would be nice.

Hey @Canedje, did you have any luck with this in the end?

I’m having exact the same issue with my setup, cheers.

Yes I did a port forward to my local IP.
And reinstall th addon
But at the moment I do run Unifi controller in a Docker at my NUC
Working fine

Ah OK, thanks for that.

It worked! So it was as simple as forwarding port 8443 to 8443 using HA’s IP in my router settings. This allows me to remote login into Unifi using my DuckDNS domain.

It makes sense to run it in its own container, I’m thinking of installing the windows version as my EliteDesk is always on anyway. I guess the benefit is, if HA goes down then Unifi doesnt die with it.

Yes But I had a Dying NUC and then the controller is also gone :face_with_raised_eyebrow: