Using WebRTC with the HACS custom Frigate Lovelace Card

I’m using the HACS custom Frigate Lovelace Card and I see that it supports WebRTC. I want to try this out to see how “realtime” I could make the stream but I cannot figure out how to enable it.

I put my RTSP URL into the settings but it still shows the Frigate RTMP stream. I have installed the WebRTC integration and HACS card as well. I have a working version of the HACS WebRTC card right next to the Frigate one and I can see there’s a large latency between the two.

Is there something I need to do to tell the Frigate Card to use the WebRTC/direct camera stream instead of the Frigate stream aside from setting the URL? I couldn’t see anything in the docs to indicate I’d need to do anything except supply the url option…

type: custom:frigate-card
frigate_url: https://frigate.local_security.mydomain.com
camera_entity: camera.front_door
webrtc:
  url: rtsp://mycamerauser:[email protected]_door_camera.mycomain.com:554/h264Preview_01_main

however, this isn’t working. :frowning:

Yikes, while playing around with the WebRTC I noticed that the stream gets corrupted… I remember seeing this previously when using Reolink’s RTSP streams in ZoneMinder and Frigate (which, I think, is why most everyone have switched to the RTMP streams instead).

image

Anyone know if there’s a fix for this in WebRTC?

any update on this, having same problem