V0.116.4 - Setting Up Netatmo Weather Station

Tags: #<Tag:0x00007f3266211458>

I’m trying to integrate my newly acquired Netatmo indoor/outdoor weather station with HA 0.116.4 (I think I’ve been trying since 0.116). I find the documentation on Netatmo a bit lacking compared to other integrations. So far, I’ve tried both methods - first, I tried the HA Cloud integration. Everything seemed to go fine (authentication completed), but no sensors ever became available. Tried reboots, etc. - to no avail.

Second, I tried the (old?) way using the developer credentials and selected “configuration.yaml” during the config process. Again, authentication went fine but nothing appeared in HA.

My understanding is that sensor detection is automatic. Does anyone know why I’m not seeing any sensors?

1 Like

Also having the same issue, my netatmo cameras show up just fine, however no sign of the weather station / sensors

Have you checked your logs? You’ll probably find an error about station_name. I’ve fixed that upstream but I’m waiting for a new release.

I’ve enabled debugging and checked the logs - it says it’s added the module weather station, no errors, but none of the sensors are created & it’s not visible under entities. I’ve tried removing and readding the integration a couple of times but no joy.

Actually I hadn’t enabled debugging properly, I am getting errors. Will patiently wait for the release :grinning:

HA 0.117.4 fixed this for me! YAY!

1 Like