Vacuum: neato showing up, but vorwerk vr200 does not


First off, I’m totally new to Home Assistant. Have successfully gotten many of my smart stuff integrated so far such as Vera, Automower, Grohe Sense Guard, etc.

I have also succeeded in getting my Neato D7 to show up using the vacuum platform neato. However, I also have a Vorwerk VR200 that does not show up. This is my config:

  - platform: neato
    name: Neato
    username: !secret neato_username
    password: !secret neato_password
  - platform: neato
    name: Alf
    username: !secret vorwerk_username
    password: !secret vorwerk_password
    vendor: 'vorwerk'

With this, I get the Neato but not the Vorwerk (called Alf :slight_smile: ).

I guess it’s something obvious that I’m missing, but I couldn’t find anything about this issue on this forum.

Thanks in advance!

your configuration is incorrect, please refer to the docs:


Thanks for the quick reply. I’ve consulted that, and this is probably where my noob-status in hass shows. I have tried this as well, but doesn’t work either:

neato Neato:
    name: Neato
    username: !secret neato_username
    password: !secret neato_password

neato Alf:
    name: Alf
    username: !secret vorwerk_username
    password: !secret vorwerk_password
    vendor: 'vorwerk'

I get this in my log when I try to check the config file prior to reloading:

Logger: aiohttp.server
Source: helpers/
First occurred: 8:42:18 PM (1 occurrences)
Last logged: 8:42:18 PM

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 418, in start
    resp = await task
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 458, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 39, in real_ip_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 73, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 127, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 129, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/", line 29, in post
    errors = await async_check_ha_config_file(["hass"])
  File "/usr/src/homeassistant/homeassistant/", line 857, in async_check_ha_config_file
    res = await check_config.async_check_ha_config_file(hass)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 130, in async_check_ha_config_file
    result[domain] = config[domain]
KeyError: 'neato'

Any pointers?


Try creating a new configuration from the integration page.

Edit: also use lowercase in the yaml keys like neato alf


Thanks for the suggestions! If I try to create a new configuration from the integration page I get the message:

## Aborted

Already configured

If I use neato neato: and neato alf: then I still get the same log error as in the last post when checking the config file.

I also tried removing the config from configuration.yaml and also removing the integration, then readding the Neato Botvac integration from the GUI. This time I put in my VOrwerk credentials, and Alf popped up. However now my Neato is orphaned. After that I tried adding

    username: !secret neato_username
    password: !secret neato_password

back to the configuration.yaml, and Neato is back, but now Alf is orphaned… :frowning:

The GUI now shows

[2 devices] and [7 entities]

but I can’t control the Vorwerk VR200 Alf.


Oh hmm we may not allow multiple accounts here for the platform. Can you open a bug on github for this? Make sure to fill out the issue template.


I havn’t ever reported anything via github before, but I tried doing it through issues:

Sorry if that is not the way I should have done it… :confused:

Thanks in any case!

Do you use the old or the new app? The vorwerk will only work if you use the old app ( with „MyKobold“ app the integrations is not working! )

1 Like

Have you opened an issue on Github regarding this?

2020-08-29 14:30:43 ERROR (SyncWorker_19) [homeassistant.components.neato] Invalid credentials

The old app is being phased out and the new one uses 2FA.

@ dshokouhi


It worked until yesterday but after update 2021.1.0, VR200 cannot be driven any longer.
I did the Neato app integration but my robot is not a Neato: it is Vorwerk and there does not seem to be a way to get that back in

Vorwerk support was dropped in 2021.1 as we now have a different auth mechanism for neato than vorwerk, a new integration will need to be added to HA with support of the different auth mechanism for it to continue to be used.