Vaillant/MultiMATIC integration

I understand it. Yes, I can control the ventilation through the Vaillant MultiMatic application.
Can I give you a username and password from my account and will you take the data you need?

PS: Sorry for my English :frowning:

No, I cannot get your username/password, but maybe visa card ? :stuck_out_tongue:

I can create a python script which will dump some data about the system and the ventilation specifically. So you will only have to run the script at your side without revealing password. Then you will just have to anonymized your data. Are you ok with that ?

Maybe you can create an issue here https://github.com/thomasgermain/vr900-connector/issues/, it will be easier to me to track the ventilation implementation.

Don’t worry for your english, mine is not perfect neither :grinning:

Hi, thank you for response this looks very nice. Now I need to wait for moving and will consider to buy the VR 920 starter pack with 3 valves. Am I right that this is no more read only so you can increase/decrease temperature for valves or room via HA?

Thanks and Regards,
M.

Hi,

yes, the vr900-connector allows you to do everything you can do on a room/zone (basically, this mean changing temperature and operation mode). As HA component uses vr900-connector you can also do the same through HA.

Kr,

Thomas

1 Like

Hi Thomas,

I am quite new at Home Assistant, but I have plans to use it in Smart Home installations.
Actually I am installing the next Vaillant system for my client:

  • Heat pump aroTHERM VWL 125/5 AS (4000 V) + VWL 127/5 IS split + ekviter. reg.multiMATIC 700
    (floor, wall heating and cooling system)
  • uniSTOR VIH RW 400 for hot water
  • heat recovery ventilation recoVAIR VAR 360/4
    and VR 920 for external access.
    So I will have quite complex Vaillant installation.
    I found your project (Vaillant component for HA) as very interesting and I could be able to support some data or test some functionality, if it could help to improve and enhance the componet for example about ventilation and finalize it as some stable version.
    Pls let me know if you are still working on it or what are your plans about it.
    Thank you.
    Peter

Hi Peter,

yeah, this is a full installation :slight_smile:. It will be very interesting to include ventilation and all other feature your devices support.

May I ask you to create an issue (at least about ventilation for now) here: https://github.com/thomasgermain/pymultiMATIC/issues (this is the underlying connector to vaillant API that HA component is using), so I can follow it easily ?

Many Thanks,

Thomas

Hi Thomas,

Just installed pymultiMATIC and the component, works great! Awesome work :smiling_face_with_three_hearts:

Still have to find a way how to git pull origin master only the vaillant component subdir; somehow I cant’ get that to work and downloaded manually the repo and moved the component dir manually. Or is there another way?

All the best and thanks for that great component (and pymultiMATIC of course),
Matthias

Hi Thomas,
my Vaillant setup is now fully functional in the following configuration:

  • flexoTherm VWF 87/4 + flluoCollect VWW 11/4 <- water-water heat hump
  • multiMatic VRC 700F/4 + VR 91F + VR71 <- wireless control for two separate heating circles (zones)
  • allStor exclusive VPS 1000/3-7 + aquaFlow VPM 20/25/2W < - buffer and hot water station
  • VR920

I’ve sucessfully set up your component (the one from your vaillant branch of home-assistant) with my system about two weeks ago and it was working great until about 2-3 days ago (I can’t say for sure, but it was around the time I updated HA to 0.102.3) , when I started getting the error below. I updated to the latest version of your component (the one using pymultimatic==0.0.6) and downgraded HA to 0.101.3 (it worked for sure on this version of HA) and it’s still the same. The sensor part works OK. But the climate component doesn’t (any more). Do you have any idea what causes this? Any help would be much appreciated.

Regards,
Tomaž

Error while setting up platform vaillant
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/entity_platform.py”, line 150, in _async_setup_platform
await asyncio.wait_for(asyncio.shield(task), SLOW_SETUP_MAX_WAIT)
File “/usr/local/lib/python3.7/asyncio/tasks.py”, line 442, in wait_for
return fut.result()
File “/config/custom_components/vaillant/climate.py”, line 88, in async_setup_platform
entity = ZoneClimate(hub.system, zone)
File “/config/custom_components/vaillant/climate.py”, line 371, in init
super().init(system, zone.id, zone.name, zone)
File “/config/custom_components/vaillant/climate.py”, line 113, in init
self._refresh(system, component)
File “/config/custom_components/vaillant/climate.py”, line 233, in _refresh
self._active_mode = self.get_active_mode()
File “/config/custom_components/vaillant/climate.py”, line 433, in get_active_mode
return self._system.get_active_mode_zone(self._component)
File “/usr/local/lib/python3.7/site-packages/pymultimatic/model/system.py”, line 98, in get_active_mode_zone
mode: ActiveMode = zone.active_mode
File “/usr/local/lib/python3.7/site-packages/pymultimatic/model/component.py”, line 71, in active_mode
setting = self.time_program.get_for(datetime.now())
File “/usr/local/lib/python3.7/site-packages/pymultimatic/model/timeprogram.py”, line 110, in get_for
tp_day = self.days[day]
KeyError: ‘monday’

Well this is wierd. I’ve reset HA multiple times and the error was still there, but today I had to cut the electricity to the complete heating system. And now everything is working OK.

Hi Matthias,

for now there is no other way. I understand this is a bit annoying. I’m gonna have a look.

Thomas

Hi Tomaž,

this is in my TODO list. I had the same issue this summer, I just shut down my boiler and multiples errors popped up. I noticed that when my boiler was down, the VRC700 was also down and in this case there is some missing information in the API (like time program). But I think in this case, you are not even able to manage your system with the android/ios app.

Thomas

Thanks a lot for your work! Exactly what I needed :slight_smile:

Nice job!!!
I’m a beginner and I can’t install this plugin, could someone help me?
I launch the sudo command …
But it shows me that the command does not exist.

Thank’s in advance

Hello,

Here is the link to the component: https://github.com/thomasgermain/home-assistant

Like any other custom component, you have to put it under /custom_component folder

It already seems much simpler seen like that.
I’m testing this right away.

Thank you for your help and once again thank you for this excellent job / sharing.

Good night.

Hello again, I unzipped the files found here https://github.com/thomasgermain/home-assistant/tree/vaillant/homeassistant/components/vaillant in the config / custom_components directory. So I end up with config / custom_components / valiant with the zip files including init.py
I have added the 3 lines in the configuration file.
After restarting my server, it tells me Component error: vaillant - Integration ‘vaillant’ not found.

Am I doing something wrong?

If someone would help me, it would be cool.

Did you unzip the zip ?

Yes i do here config / custom_components
So i have the files here config / custom_components / valiant

is it a typo in your post or the folder is really named valiant ?

Because it should be named vaillant

Hi
I am building my new home and i think about buy heater gas to my home. I think about Viessmann and Vaillant. Many user recomnded me Vaillant. I have a questions:

  1. is any chance to add this component to official Home Assistant release ?
  2. What model heater gas support your component ?