Vallox Integration not visible in HASS installed on Ubuntu


At first disclaimer, I’m new to Home Assistant and just managed to get it installed as virtual machine to VirtualBox running Ubuntu. I would be interested to try interaction with Vallox unit. Vallox can be found under Integrations in web page, but I was not able to find it from HASS installed to VirtualBox. Any advice how to get it to there?

Thanks, Rampe

The outcome was the same for normal Ubuntu 16.04 install - for VirtualBox used 18.04. Can see the Vallox in Integrations webpage, but not in installed to Ubuntu. Anybody to advice a newbie here? Home Assistant version 0.98.4

If you see it in the integrations page on the website but don’t see it as an option in integrations on your HA, you have to manually add it to the configuration yaml. Just follow the instructions for the component

Thanks. I tried to follow the instructions and modified the configuration.yaml to be the following. Then tried re-fresh of Hass. Can’t see the Vallox under Integrations. What I’m missing?

# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

  name: Vallox145MV

You won’t see it under integrations…

Vallox FW version is 1.8.10. I can access to Vallox through it’s web interface dashboard via same IP address as used below. Python version is 2.7. Due to py2.7 installed the 1.5.2 of Vallox websocket API from with pip install vallox-websocket-api==1.5.2

Installation was okay:

Tried to follow the instructions in



I do not see any changes. What kind of a change(s) should be visible in Hass and where in it when the change/setup is successful? What I need to do except gain more experience on the platform :slight_smile:

You didn’t need to install anything. The component/integration is already included in home assistant.

You would see the component in your developer tools states page.

Here’s the current view, after previous actions

Correct view (for states)?


Just an FYI, your 192.168 address doesn’t need to be hidden. It’s a non routeable address.

FYI noted, thanks. However it’s not 192.Xxx… which is hidden, its 172.Xxx… eth0 is in 192.Xxx… local DNS, like the Vallox145 too. But for some reason hassio and docker0 are in 172.Xxx… Just didn’t understood those yet, so kept those hidden.

Could that explain why there is (at least for my eyes) nothing related to Vallox in the states view? Or is there something else to explain it? And how to get Vallox to show up?

Docker has an internal subnet it uses.

You haven’t explained how you are running the docker image, but you need to use net=host to make sure ha is available outside of the host.

I just followed the instructions “Install on generic Linux host”. It’s on top of 16.04 Ubuntu. Any other info needed on docker?

So the range of 172.Xxx… that docker0 and hassio use are also private. DNS does not have anything set for 172.Xxx. - only supporting 192.Xxx…

Any links/tips for net=host usage? I’m newbie for docker configuration too - just used those couple of times before.

So you’re running hassio. That makes a difference.

You don’t need any DNS.

If you’re running hassio, it’s already enabled.

You don’t need to use 172.16.x.x to access HA. You can access the host IP.

Sorry, local network DHCP (not DNS) has nothing for 172.Xx, range is for 192.Xx

From browser can access HA with 172.Xx…1:8123 - can also access Vallox with - but why HA can’t see Vallox? There’s nothing on states?

I’m new to dockers too, but here is the output from docker trying to ping while connected to LAN without access to internet (explains why fails)

At the same time browser (Firefox) can successfully access Vallox

After enabling connection to internet, with the same docker can ping and get replies from

So why the hassio running inside docker can’t see/ping Vallox at 192.Xx… if the browser can access to it?

First of all, stop blurring out your private IP addresses. Nobody can ever connect to those and you blurring them out just makes it impossible to troubleshoot. How do I know you are using the right IPs?

Secondly, what subnet is your Ubuntu (Docker HOST) on? same subnet? Does your router (wifi) block communication between wifi devices and wired devices? Is your Ubuntu machine configured with a correct gateway? netmask?

Hope this sketch clarifies the topology. Now - no blurring - perhaps some answers? :wink:

alright, so ignore the fact that docker has a different network. It doesn’t matter. If you don’t have a firewall turned on at the Ubuntu host, it doesn’t matter. It should be flowing through there. You should have access to your HA at

Does your Ubuntu machine have proper networking? Netmask? Gateway?

Based on your drawing, your hassio doesn’t have INTERNET access? Why?

What is .100? Is that just your DHCP and DNS server? What’s the gateway? Can anything talk to the gateway for the network?

Yes, have the connection to HA also via that, from Ubuntu and also from the machine .100 working as DHCP&DNS.

Ubuntu route -n output below.

There is not internet access, unless I connect the Ubuntu via wireless to the router, because the system will be a standalone functioning only in local network.

.100 is basically a Windows 10 PC, running OpenDHCPServer. Gateway, by the OpenDHCP documentation, is by default the Router. Router in that case is Ubuntu can’t “talk” i.e. get resp to ping from it. Itself can ping itself and get responses. Other devices I haven’t tried yet.

You can’t ping your ‘gateway’?

It seems to me like you just have a broken network. I don’t see much value in Home Assistant in a completely offline environment, but good luck to you.