Velux Component for KLF 200 doesn't support the new API with Firmware 2.0.0.71

Ciao Fabio,

It is needed to power cycle klf200 random times…say 1 time every 10 you restart HA.
It mostly happen when you update HA actually which could be due to a not clean disconnections from klf200

Once HA is started and connected it is rock solid: I have quite few automations on Velux (Windows, covers, shades…) and they work beautifully

Ok, thx for info… Do you have somekind of sensor so you can actually see if klf is connected or not?.. So you can send somekind of notification… That way I can do an automation to power cycle the klf…

Or can you only see it in log files and restart HA?

I tried to unplug/replug it many times yes.

Hi,

I added 2 (garage door and a velux cover) before trying to connect the KLF200 to HA.
I have 4 devices in the KLF’s web GUI (1 cover, 1 garage door, 1 light associated to door and 1 on/off switch that seems to be the same than the light).

I took a glanced at the pyvlx.py code (which is what HA uses) along with your log.
The log says ValueError: 378 is not a valid NodeTypeWithSubtype
378 is x17A in hex. The API doc for that type says the following:

0x017A Linear or angular position of the garage door

The code NodeTypewithSubtype() itself has a list of “enum” items that it supports, and 0x017A is not in the list. There is however one that is close to it: LINAR_ANGULAR_POSITION_OF_GARAGE_DOOR = 0x140
To me this is a hint that the code actually supports a garage door similar to yours.

My recommendation would be to send the author of the pyvlyx.py code an email to see if he can add the 0x017A to the list.

Here is the project page, and at the bottom you’ll see the author’s contact.

If you know how to get to the code, it would be an easy change the 0x140 to an 0x17A, then just try it out.

See this interesting reply :

Hi @wmaker,

Thank you for your answer. I will open an issue on pyvlx github.
I not a python guy but I’m a developer. I can try some things directly in pyvlyx.py but I don’t find it :frowning:

I can’t access /usr/local/lib/python3.7/site-packages/pyvlx/nodes.py through ssh. python3.7 is not in /usr/local/lib/ folder.

Do you have any hint about it ?

I will also try to remove the garage door and just make sure the velux cover work.

I’ve only started playing around with Hassio recently as I mainly use HA Core.
I did manage to sorta hack into Hassio. Here is what I did:

You’ll want to get to the system’s “main hassOS console” (rather than the SSH addon). The “main hassOS console” gets you a login prompt (username root, no password), which gets you access to HA CLI, then enter “login” which will get you to a linux shell.
You will know you are at the right place if you enter $docker ps and you see a docker container named homeassistant.

Next enter $ docker exec -it homeassistant /bin/sh This will get you to a shell inside the homeassistant docker container. From here you should be able to get to the pyvlx files. Just be careful, as you’re inside a docker container. Make sure to make a backup of the file you’re modifying. Good Luck!

Guys, me velux were installed today
i have 2 windows (integra electrical)and also 2 sun protectors outside
some questions about setup for klf200 , i have it working though in HA , but i am not sure about setup

at the moment, the integra windows, the motor is not installed yet, so i am starting with the 2 sun protectors (electrical)

the left sun protector i have configured at input nr 3
the right sunprotector i have configured at input nr 4

questions
1)
according to manual , you need to configure a set of inputs?
so input 1 is for opening, input 2 for closing? but thats not needed? we only need 1 input for 1 sun protector? i have just followed manual, i press the reset button on my wall switch, i press the reset button on KLF … done
in HA, i can see my 2 covers created, and i can open / close them seperately

also second, the inputs with blue wires … do we need to configure them also? according to manual its ro receive the state … but i can see the state perfectly in HA if i close/open my sun protectors?

yesterday, when i restarted HA, the velux component was not able to setup, had indeed to reboot the KLF200

i thought the connection was dropped after 15 minutes? i rebooted HA after several hours of uptime

though i cant reproduce, if i keep on restarting HA now every minute it everytime loads succesfull :slight_smile:

1 Like

for info:
Nice guy @pawlizio created a HACS custom component, actually it reboots the gateway upon restart / reboot HA
so no need to power off/on the gateway anymore

also this automation is needed :

- id: 'KLF_reboot'
  initial_state: 'on'
  alias: KLF reboot on hass stop event
  description: ''
  trigger:
  - event_data: {}
    event_type: homeassistant_stop
    platform: event
  condition: []
  action:
  - data: {}
    service: my_velux.reboot_gateway
  mode: single
2 Likes

Thank you!!

hi,

hi, i know we can use this integration in HA
but does anyone know if we can use the KLF with Rest API commands, like Curl ?
anyone got an example?

This automation is different than the official one : Velux - Home Assistant
I was able get my velux working with but not anymore even if i reboot the KLF manually.
So for me nothing works.
Please need some help to figure it out :wink:

I do the automation restart when I do a restart of HA, not upon start

It worked back

Hi,

I bought a Velux KLF200 and I have connected and “paired” with my IO devices (I can show my Somfy IO devices), but I can’t integrated on my HA, I tryed with restart and some differents passwords… but I show always this message!

Someone can I help me, please?

image

Did you try the password on back?

Yes I tryed with this “velux123”

Hmm, I’ll have a look at my password Tomorrow