Venetian blind


I am despairing. I’ve been trying to get my blinds to work for days. If they are trained as a roller blind, it works. Say if I say alexa set the blinds to 0 then they go down. Set to venetian blind, the following happens: alexa set the blind to 0 then the venetian blind moves to 0 and then the slats turn to the half position instead of staying fully closed.

  1. Problem is this:
    Would like to be able to change the slat position with an automation. Nothing happens with cover.close_cover_tilt and cover.set_cover_tilt_position.

Hope for help from you.

In order to help you you need to give more information. What integration/brand/device are you using? Or is is a template cover, if so how did you set it up? It is probably something specific to the integration you use. I have no problems with venetian blinds using the Motion Blinds integration.

One generic thing that I can come up with though, is could it be to do with device calibration? Maybe the tilt calibration is somehow reversed?

Thanks for your answere.
Sorry I used a fibaro rollershutter 2/3 and tried also a qubino flush shutter.
Everything is calibrated.
Slat’s tilting full turn time was also wagered

Seems to be an Amazon issue. Had this a few days ago. After powering off my Echo Show and removing all related routines it is working again.

For HA: Use cover.set_cover_position

cover.set_cover_position doesen’t work for me.
What devices have you?

Still the question I asked earlier remains relevant. You’re using z-wave devices, but with what integration and z-wave controller hardware? zwavejs2mqtt, zwavejs? A quick search over the forum discovered posts like these:

That post of mine isn’t relevant anymore. The tilt support has been added by somebody else in upstream since :+1:

I use the aeotec z-wave stick gen5 and the zwavejs integration.

Is it better switch to zwave2mqtt?

nobody have a fibaro rollershutter or a qubino flush shutter with the tilt option working?

I think this is not working because the tilt position is a separate entity in Home Assistant (instead of only one entity for up/down and tilt). I have the same problem. First I thought this problem is a special behaviour of the Fibaro, but today I have tried it with a qubino and there the tilt is also listed as own entity.


I have also opened an issue on github months ago, but nobody can help :frowning:

1 Like

Dear all
I recently started playing around with HA. So I’m new to all.

But the way how HA treats the tilt manipulation is similar to waht openHAB does too. The only difference is in openHAB it is more clearly named or identifyable compared to HA.
In my case I’m working with the Qubino (Goat) shutters but I’m far away to say I’d like the setup as of now.


any Update?