Venstar T7900 & Trane Air Conditioning / Amana Forced Air Furnace

I’m having two issues with the integration of a Venstar T700 Thermostat. I picked this unit because of the built in WiFi capability and local API (for HA integration).
1.) It will not connect to my Ubiquiti based WiFi set up. I’ve tried with the SSID viable and hidden. I’ve defaulted the Venstar unit and verified the firmware is at the latest release. Has anyone had a similar issues in connecting their Venstar to WiFi and how was it resolved.

2.) Is the unit compatible with a Trane XR13 3 Ton Air Conditioner / Amana Forced Air Furnace? At times we get a very loud, generator like sound coming from the outside AC unit. The dealer thinks the AC might be running backwards and suggests the thermostat is to blame. I’m wondering if the thermostat was set up incorrectly. Has anyone experienced this and is there a way to set up the thermostat to work with the AC? I see there are three dip switch on the MB but I’m not sure of the correct position.

Thanks in advance for any help that can be provided.

I managed to get the Venstar Thermostat connected to WiFi. There are two settings that need to be turned off via Unifi Controller.
1.) On the actual WiFi Vlan make sure the “2G Data Rate Control” is off
2.) For the whole site make sure “Auto-Optimize Network” is turned off


Unfortunately this does not seem to be “enough” anymore.

I recently installed a t7850. I don’t know what firmware version was on it, but after installing I went to set up WiFI and the AP did not show up when I scanned. I was able to manually add the name/password and the thermostat connected.

Shortly after, it updated to the latest firmware 6.91 and was fine for … about a day. This morning, none of my climate automations were working. I went to check and the thermostat has a “red” wifi symbol and has not been able to connect. I have tried rebooting it and the AP but no luck.

I have created a dedicated network just for it with the suggested 2g rate control: off and site optimization has always been off for my network. The thermostat does not connect… but it does see the AP in the scan results, though.

I have a standard ssl/mitm AP that runs on an old raspberry pi and the thermostat was able to connect to that without issue :(.

Have you tried contacting Venstar support? They may have some answers and were quick to respond. Here’s the email address I used.

Venstar Thermostat Support
[email protected]

Totally unrelated, but I have three Ubiquit Access Points; two are the LR-AP (they look like a flying saucer) and the third one is a newly installed FlexHD. I found one of my light switches had connected to the FlexHD however I couldn’t ping it or connect via home assistant. I wound up powering down the FlexHD and allowing the light switch to connect to the network via the LR-AP. Then I powered up the FlexHD. Generally speaking I find spending more time than necessary diagnosing entities that aren’t “available”. I’ve got three right now in this state.