Verisure module fails

Okay, another topic from me. Hope you don’t find me annoying ;).

When I have added the verdure module, typed in the correct username and password, used the correct spacing for the yams file. I still get these errors:

17-01-29 13:19:51 ERROR (Thread-6) [homeassistant.components.verisure] Could not log in to verisure mypages, HTTPSConnectionPool(host='', port=443): Read timed out. (read timeout=10)
17-01-29 13:19:51 ERROR (MainThread) [homeassistant.bootstrap] component verisure failed to initialize

Why is this and is there any way to fix it? Do I need to include quotes around my username and password in the yaml file? Here is the yaml btw:

  username: REMOVED
  password: REMOVED

Thing is, it worked earlier, exactly with this configuration.

Problem solved itself, just waited it out.

Ok, here’s the thing. When HA has been alive for some time (around 10 minutes or more), I get this error message:

homeassistant.components.verisure:Caught connection error HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /settings/smartplug (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x6f6b7d50>: Failed to establish a new connection: [Errno 110] Connection timed out',)), tries to reconnect

Is this anything to worry about?

After I send any message to verisure using HA it doesn’t really go through to the other end and no visible change can be seen at the smart-plug.

Does this work properly now? I tried to connect first time and got similar error message.