Version 2.0 setup not recognising nabu casa setup

My iPhone is set to auto-update apps and this morning I find that the hassio companion app has been updated to a completely new version with breaking changes.
: this is very poor practice. If an app date requires complete new setup and has breaking changes it should be released as a new app, not as an update that could break existing installations - potentially when the user is far away from home and dependent on having working remote access.

Anyway, I was at home and the app went through its setup, but it hasn’t recognised nabu casa. Now I am out of the house and I cannot connect to HA because the internal URL is in the external URL field and I cannot change it without getting an error.

Luckily I can still access HA through the browser, so nothing wrong with nabu casa.

Sorry you’ve had a bad update experience. Releasing as a new app was discussed but I suspect supporting two apps wasn’t going to happen.
Anyway here is what likely happened on your update:
The updated app requires always-on access to location data which since ios13 includes the wifi ssid in order to determine internal/external. It falls back to external.

If you add that internal access by allowing location it should detect nabu casa and that checkbox should become available once you enter your internal url.

It is possible it might take a restart of the app for the nabu checkbox to be available.

This all assumes that the app detected nabu during onboarding and set up the relevant webhook for you (you can check that ny going to the cloud integration in ha and looking for webhooks set up by mobile_app.

Hope you’ll get it sorted with this.
-Jan

Thanks, Jan.
I’ll have another go when I get back home later today.

Gareth

No luck.
I checked location services and it is set to ‘always’. The iphone is up to date and has been rebooted.
I reset the app, quit and started afresh. It found hass and recognised nabu casa after I authenticated. It had the local IP address in external url. Internal URL was blank.

I quit the app and disconnected from wifi so that it would try and access over 3G. When I launched the app it just reported a timeout. It still had the internal IP address in external url and the internal url was blank.

Unfortunately because Apple changed the iOS permissions with iOS 13 this is a bit more complicated:

  1. Copy and paste what’s in external URL to internal URL (while on your Wifi)
  2. Possibly restart the app
  3. You should now have the checkbox for “Connect via Cloud” available, activate that.

You’re done.
The reason for this is that during onboarding the app can no longer assume that it has access to SSIDs, so whatever is entered/detected will be set up as external URL. Whenever there is no Internal URL and with only External URL available the Cloud checkbox isn’t active.

Thanks, that worked.
I don’t recall seeing these incantations mentioned in the “Getting Started” guide for the app. That guide only gets you as far as connecting locally and makes no mention of the hoops that need to be jumped through to connect remotely. Or did I miss it?

I think we missed that. We’ll fix the guide.

1 Like

Excellent. I’m sure it will save you some support interactions :slight_smile:

Gareth

Hi @olbjan,

I am pretty much having the same issue. I did what you suggested above but I can’t get the checkbox to login through Nabu Casa. What should I do?

Thanks

Same, trying to make this work.

hi @olbjan,
I am having the same issue, the Nabu Casa remote access check mark will not appear after trying the steps above. I have also tried reinstalling the app with no joy.

Home assistant version 108.3
iOS 13.4.1

Thank you for the help in advance

Same issue here. I tried recommended steps without any luck.

Did you get it solved? I have the same issue after migrating from duckdns to Nabu Casa

Yep, I managed to solve it by re-installing the app (reset only didn’t work).

I am struggling with this issue too - I’ve tried the two solutions I could see in this thread.

I can see the internal IP in both the internal and external fields. Restarting the app doesn’t show the cloud tickbox.

I have deleted and reinstalled the app as well to no avail (same as above - internal IP in both fields).

The app does say on registration that cloud is recognised, and the integration, sensors and webhook are created in Home Assistant (running hassio).

Any ideas on how can I force the app to recognise nabu casa? Remote access is definitely connected.

+1

Same issue. Copied External URL to Internal URL field, then restarted – nothing changed. No “connect via cloud” box to click.

I was having the same issues, but I finally got it working this morning.
The change that finally made it work for me was to enable Remote Control in the Home Assistant Cloud configuration page. While you’re there, make sure the Webhooks are enabled too. I restarted my HA server just in case, but ymmv.
Even though the cloud was showing ‘Connected’, and I could access it fine from logging in via the nabu casa web page, this option was disabled.
I enabled that, restarted the iOS app, and lo and behold, the option for Connect via Cloud came up.

Other points:
Make sure you properly close the iOS app - don’t just home-button back to the home screen. Make sure you swipe it up closed.
After enabling connect via cloud, I clicked Done, then restarted the app.
Then remove external IP address, so it’s now blank.
Only after doing all this, did I then disconnect from the wifi.
The first time I was not on the wifi I had to restart the app to make it connect via cloud. After that, it’s been fine.
Hope that helps someone. I’ve spent the last three days trying to get this working. But now it is :partying_face:

Mine has magically starting working now too. But I didn’t do anything different! :slight_smile:

I still have the issue. I reinstalled app. Reconnected. While installing it says nabu casa recognized. Nabu casa works. However the app is not recognizing NC. Login from outside the network is not working. Sad. Any other way to trouble shoot that?

Now working for me too – used the same procedure as @harro (above)

Went to Configuration -> Home Assistant Cloud -> Remote Control and disabled it.

Restarted Home Assistant Server.

Went back to Config -> Home Assistant Cloud -> Remote Control and enabled it.

I went to App Configuration in the iOS app and did a Reset

I then did a Force Close of the iOS app and restarted it – it put me through the setup process again but then the “Connect via Cloud” option was now listed.

2 Likes