Vertical-stack-in-cards question

I am trying to get two different cards to work in the vsic.
Here is my code - still shows up as two seperate items.

type: custom:vertical-stack-in-card
  - type: entities
      - entity:  sensor.server_arraystatus
        name: Array Status
        icon: mdi:server
      - entity:  sensor.server_arrayprotection
        name: Parity
        icon: mdi:server    
      - entity:  sensor.server_cpu
        name: CPU
        icon: mdi:cpu-64-bit
      - entity: sensor.server_memory
        name: Memory
        icon: mdi:memory
      - entity: sensor.server_diskspace
        name: Disk Space
        icon: mdi:harddisk
  - type: custom:bar-card
    title_position: inside
    align: center
    padding: 4px
      - entity: sensor.glances_cpu_used_2
        title: CPU
      - entity: sensor.glances_ram_used_percent_2
        title: RAM
    - value: 50
      color: '#00ff0d'
    - value: 70
      color: '#f6ff00'
    - value: 100
      color: '#ff0000'   

What is the proper way to add it - I see this from github
vertical-stack-in-card inside your ui-lovelace.yaml


  • url: /local/vertical-stack-in-card.js?v=0.1.3
    type: js

but from the HACS install:

-url: /hacsfiles/vertical-stack-in-card/vertical-stack-in-card.js
type: module

I’m using the url from hacs but am seeing this in logs

hacsfiles/vertical-stack-in-card/vertical-stack-in-card.js:176:0 NotSupportedError: ‘vertical-stack-in-card’ has already been defined as a custom element

Same error if I point the url to /local/community which is where the folder is actually at.

I even tried just the vertical-stack card and that shows up as two different cards and not stacked. Any help would be great.

OK that’s messed up but I got it to work by looking at someone elses yaml card - it wasn’t working due to indentations…wow.