Very basic question on first time start up and initial OS install for HA Yellow

I ordered the HA Yellow in October 2021 and it was delivered in January 2023. During that time I was also searching for a Pi CM4, and I recently was able to purchase a CM4 Lite 2G without Wi-Fi which I now have.

So I have installed the CM4 and a 256GB M.2 PCI-e NVME on the HA main board per the FAQs.

I’m confused by the steps in “Getting Started” It suggests that I simply apply power, connect Ethernet, and the HA is up and running on my network?
What is the OS install process for a HA with a CM4 that came from DigiKey and an NVME that is new and unformatted? Is there some bootable memory on the HA mainboard that the CM4 can boot from and get running?

This article talks about how to install the OS for a CM4, but maybe the HA is different?

Just work along the correct installation instructions. :wink: What you linked in your post is the documentation of the pre-assembled Yellow. What you need, and what you have in terms of hardware, is the “Home Assistant Yellow Kit with NVMe”. There are complete instructions on how to install hard- and software.

See here:

Thank you for providing the link to the “Kit” instructions.
I’ve got everything installed, and completed down to
Step 13 Reconnecting power.

It started up and resumed the yellow heartbeat blink.
The web page at http://homeassistant.local:8123/onboarding.html says it’s finishing, and will be done in 20 minutes. It has been on that page for 14 hours, and still yellow heartbeat.

Unplug power and restart again?

So you reconnected the power and can access the homeassistant.local:8123/onboarding.html page? Have you tried to reach HA by omitting the /onboarding.html? Just try http://homeassistant.local:8123 and see, if you can reach HA. If not, I’d say, yes, unplug it and restart it again. Maybe something got stuck.

It can be, that something went sideways, but you can’t do any harm in unplugging and starting it again. If it hasn’t finished the installation, you can always start the installation again. So no harm done. :slight_smile:

OK, I restarted, and I now get to to the onboarding.
I entered my name, and next entered my location.
That gives the error “Network Error when attempting to fetch resource.”

The HA is clearly connected to the network, since I’m reaching it from another machine’s browser.
Internet on the network is working fine.

It will not let me click Next.

Can I just SSH in and complete the setup rather than this “onboarding process”?

Got this message this afternoon too. I think I just reloaded the page and did not enter a location, then clicked next

I re-loaded the page, and it goes to http://homeassistant.local:8123/auth/authorize?
“You’re about to give http://homeassistant.local:8123/ access to your Home Assistant instance.”

I enter the username and password I just created and get “Invalid username or password”

I tried SSH, and it is refused.
Is it time to format the NVME and start over?

I started following the process for lockout here: I'm Locked Out! - Home Assistant

It says "If you lose the password associated with the owner account and the steps above do not work to reset the password, the only way to resolve this is to delete all the authentication data. You do this by shutting down Home Assistant "

How do I shut down HA to delete those files? I can’t get to a CLI with SSH, and there is no HDMI like a regular Raspberry Pi.

Normally you could remove the following files from your /config/.storage folder and re begin the whole process. In your case it might be better to flash the system again (as new)

  • auth
  • auth_provider.homeassistant
  • onboarding
  • hassio
  • cloud

Thanks all for the help. Got it going.
Now my first task is getting SSH installed. I don’t like not having access to my own server other than a webpage. Found “Home Assistant Add-on: Terminal & SSH” and installed and configured per docs.
HA SSH not working with Putty client and PuttyGen RSA keys - “Server refused our key”

I’ll search more here, and start a new thread on SSH.