Very inconsistent data from ir sensor

So I was trying to control my daikin AC (model FTKS25AXV1H/RKS25AXV1H) with esphome, but all daikin ir remote modules failed. I also tried the suggestion from there and used the arduino heatpumpir lib

but the AC did not respond

then I tried to do the steps here and tried to copy the remote manually:

it got recognised as a pronto protocol but the codes were all over the place. They were way too long and different each time.

I then tried another remote from a denon AVR and pressed the mute button. I found out that the code were all different.

What should I do next? can anyone help me to find the exact code to replicate?

here are my configs:

remote_receiver:
  pin:
    number: GPIO14
    inverted: True
    mode: INPUT_PULLUP
  dump: raw

remote_transmitter:
  pin: GPIO13
  carrier_duty_percent: 50%

After some tinkering, I used the IRremoteESP8266 library on a, well, esp8266 and discovered that it seems to use the DAIKIN64 protocol. I spammed multiple commands, which seem to decode the output 1/10 of all tries. I will continue to document my findings.

I also discovered that my remote seems to be a BRC52A62 by shear luck after googling the aircon model number and the term “ir code”.

It seems that the library correctly digests the IR remote.

here are some of the results:

Edit: it seems that it still cannot output the correct code. I wonder if the IR LED is not suitable in the first place…

Hey, I think I have the same problem as you, did you manage to fix it?
I tried ESPhome daikin protocols but couldn’t get them to work, so I installed Tasmota and set up Tasmota HRVAC integration, works just fine (DAIKIN64), however I get a lot of status desyncs and wonder if I can get better results with the right esphome driver

I haven’t been able to achieve any meaningful progress until autumn. Then I’ve put that off until recently. Any progress on your side?

I finally figured out the issue.

  1. My ir sensor is 5V and 5V only. Attempting to use 3.3 would not work and results in garbage data.
  2. Even if the voltage is correct, the issue is that the IR sensor might not reliability pick it up. Repeat multiple times until you got something expected.
  3. The state is inverterted, send a ON results in a OFF

I dont care to install yet another MQTT broker and yet another thing to my stack, but it might not for you. I ultimately used tasmota as you said it worked, and it did

Edit: requested daikin64 code in Add support for daikin64 ir remote codes · Issue #2670 · esphome/feature-requests · GitHub