Very slow response to remote commands

Hi
I used to have 2 Apple TV device but have upgraded to Shield TV devices and have noticed massive delays in sending remote commands.
When I was using the Apple TV devices the remote commands were very snappy with very minimal lag perhaps 1 millisecond.
How ever the Android TV integration is horrible its adding significant delays between each command.
This is annoying when trying to navigate Plex or Netflix to scroll through media.
I have put up with this for a few months now but this got 10 times worse with the recent update to Home assistant as the Android TV integration added the screen cap feature ( No way to disable this yet :frowning: )

I understand that the process of sending the commands to the shield TV via ADB could be adding delays and now since the screen caps are coming through via ADB also its slowing things down alot more.

If I install the Android TV app on my phone the navigation is perfect and 100 times faster than what I’m getting via Home assistant.

So I had a Harmony hub sitting spare so I decided to get this setup and tested everything through the harmony app and its perfect exactly like using the android TV app.
I setup the harmony hub integration and got this working but the lag is the same as it was with ADB ( Prior to the screen cap feature being added)

So now I’m thinking maybe this is some sort of limitation of Home assistant but since the Apple TV integration worked fine I don’t know what to think now its annoying the hell out of me

I have designed my whole home assistant front end around having a single app to control everything in my house. I’m not just sending remote commands as part of automation I’m using remote commands to completely replace the psychical remote the lag almost makes it un usable.

Just wondering if anyone has had the same issues and managed to fix the delay or if anyone knows why this is happening?

Can you test something for me? I use xiaomi Android TV box. It is also slow when I use an app. For me that was solved by disabling hdmi-cec control.

I’ve fully disabled HDMI-CEC but that made no difference unfortunately.

Ok, to bad. Thank you for trying though. Have you got a lot of other app’s on the shield? I’ve also disabled all apps I don’t use. Things like Google calendar and Roku. So I only have YouTube, Kodi and Spotify enabled now. That helped a little too. Not as much as disabling hdmi-cec though, but maybe that’s a xiaomi thing.

Both shield TV’s have bear-bones apps on them.
I don’t think its the shield its self i’m thinking its the interface between home assistant and the harmony hub seems like there is a massive delay being added in somewhere.
If it use the Harmony remote app its perfect no perceivable lag what so ever.
seems the majority of people don’t use home assistant in this way to replace a physical remote.
I will keep looking for solutions :slight_smile: thanks for trying to help.

Ok, that is weird, since ADB and the harmony show the same delay’s but other “remotes” don’t. And if you use the HA+harmony to control a normal tv or something does is also show these delays?

My adb commands worked ok and then slowed down recently after .108. I just removed the media card since I only used the power on/off and that fixed the long delay. I think the media card trying to display what was playing used to much bandwidth, just a guess.

I am having the same issue with android box too.

seems that you can disable the screencap on the media player with yaml config. It help a bit, but I still have less than 1 second delay. I will see, if it won’t get worse.