Very strange issue--can't create "icons" folder in /www

I’ve been, over the course of a month or so, trying to add DarkSky to HA. I keep coming back to it as I’m having a bizarre issue. I actually have everything working and showing up in Lovelace except for the icons. I can’t complete this step in the installation instructions:

  1. Download the amcharts icons from and put them in <config-dir>/www/icons/weather_icons. Create the directories if necessary.
    You should end up with the following folders:

I can create any other folder in /www/ except for one named “icons”! I can create a new folder, but the moment I try to rename it “icons,” I get a Windows error, “could no longer find this item.”

In the meantime, I’ve created a folder named “icon” and placed the icon folders there, and that works just fine (at least, from a file structure standpoint):

However, despite editing lovelace-darksky-card.js to point to the icon directory, the icons don’t show up in Lovelace. I suspect that lovelace-darksky-card.js.gz also needs to be changed, but I think that’s compiled. Ideally, I’d be able to figure out why I can’t create the icons folder so I don’t run into any issues down the line (for plugin updating, for example).

Any ideas?

what hassio installation are you under?vm,supervised,OS or docker

  • you should try with ssh and check folders, files and permissions if needed (ls -l)
  • maybe check your samba rules.
  • maybe ‘show hiden files & folder in windows’

[quote=“tomdudu38, post:2, topic:319277, full:true”]
what hassio installation are you under?vm,supervised,OS or docker[/quote]
Argh, sorry, I meant to include that but rushed my post. Supervised HA Core 2021.6.6, running on VM.

  • you should try with ssh and check folders, files and permissions if needed (ls -l)

In all my attempts to SSH in, I’ve been unable to (via PuTTY), HA VM IP, port 24. I can however use the Terminal & SSH plugin and navigate over to the /www directory in the “web UI.” For whatever reason, the resolution is terrible, but here’s what I’m seeing:

Not sure about Samba rules, but I have hidden files showing as well as extensions by default. I confirmed that again this morning.

EDIT: I want to re-emphasize, I can create a folder in there with literally any name other than “icons:”

Go to your SAMBA share addon and remove icon? from the veto_files configuration option.

This has confused many people.


Holy cow. Yep. Thanks so much. I was finally able to change the name of the existing “icon” folder to “icons,” and the Lovelace view instantly updated with the icons.

I feel slightly better that I’m not the only one to have run into this…!

1 Like

Thank you DeltaNu1142 - !!! I just spent almost 3 hours trying to figure out this exact issue. I finally stumbled on to this post and it solved it in 30 seconds. This helps return my sanity!

1 Like

I had this same issue for almost a year and just kept avoiding doing anything that required the folder, thinking that the issue was isolated to my system. I decided it was time and after a few min I found this thread and of course, you had the answer immediately. Just wanted to say a long overdue thank you. You have saved me so much time over the past year. Really I appreciate it, you are the man.

1 Like