Very, very strange boot issue on Rpi 3b+

Hi there!

New here and trying to get started.

Running into a very weird issue - I am able to get Home Assitant for Rpi to boot on my 3b, but it will not boot on my 3b+ (using the same SD card).

I’ve confirmed that my 3b+ will boot from other Rpi images (Octoprint, PiOS, etc).

Curious if anyone has run into this issue before? I’ve been scouring the web for quite awhile now, changed the config.txt for HDMI out etc - but the I/O light on the Rpi 3b+ just isn’t blinking as it is with other images.

Strangely it appears that the hostname / network interface does go up (when checking my router clients), though I can’t connect to it over browser or SSH like I can with the 3b.

Thanks in advance!

Have you tried using a separate SD card with a fresh HA install on the 3b+?

yup, that’s exactly what i’m doing - i’ve tried two high quality microSD cards, and they both boot on the Raspberry Pi 3B (but not the 3B+). As mentioned, I’m able to booth other Operating Systems on the Rpi 3B+ - just not Home Assistant.

I imaged the MicroSD card using Raspberry Pi Imager - perhaps I should try something else?

Just to confirm that the SD card for the 3b+ was never booted in the 3b?

it was, but then i reformatted it and put HA on it fresh

Not sure but this feels like maybe a networking issue. I would try deleting the DHCP reservations in the router (for both the 3b and 3b+ then try just booting the fresh 3b+.

thanks for the tip -

I have an HDMI screen attached and it’s just not booting (regardless of whether or not network is attached). I also tried booting it from a USB stick, no dice.

So far I have booted to PINN (the network installer), and OctoPi.

This is really odd it seems to be exclusive just to installing HAOS on Pi 3b+ - I am at my wit’s end!

FYI looks like other people are having this issue: