/video/liveplg.asp# help adapting to better use

I have an unlabeled chinese P2P cam that uses that url with an ActiveX control (via internet explorer) to view live video and audio at 1080p with 30fps [with controls for resolution, brightness, contrast, and detail, multi-camera tiling, muting or sound]. It is not upscaled. It is an excellent image.

this is another interesting URL match

as is this possibly related stack post

I myself have been unable to find a suitable path port combination for RTSP (via VLC).

From it’s settings page /setting.asp I changed the port as verizon was not allowing connection with port 80.

however when I changed the port, subsequently creating port forward, the android apps would not access the camera outside the lan :frowning:

hdminicampro is the least horrible, non-malware android app (as of version 1.9.2 s)

The top iframe of settings is
IPCam 209
Ver 1.9.8 D

Which is all the more interesting as I bought it in April 2018.

system about slightly redacted

|Device SN|22C0nnnnnn|
| --- | --- |
|Hardware Version|2.0|
|Firmware Version|1.9.8 D|
|Lan MAC||
|WiFi MAC|fc:ee:e6:nnnnnn|

I am not thrilled having had to setup a windows 10 machine for internet explorer 10 to use an ActiveX control. There is another stream URL but it is lower FPS at 1080p without sound


While /video/liveplg.asp can be video-only viewed with android browser the controls cannot be actuated. Viewed by any desktop browser the video is not available replaced by a prompt to download a windows installation wrapper for ActiveX control.

the firmware update page flippantly warns not to use wifi - which is the only interface.

palemoon NPAPI will not pickup the control :frowning:

I’m not buying something else so let’s not have “helpful” advice like that.

What has this got to do with home assistant?

You can add this to your configuration.yaml

  • platform: generic
    name: chinesecam
    still_image_url: http://YOUR_IP/snapshot.cgi?user=admin&pwd=