Vimar 14594 blind actuator unresponsive on large zigbee networks

Hello everyone,

I’m having a lot of troubles using this device from Vimar:

It is a Zigbee and BLE blind actuator with position and state reporting, all in one small device.

As I read on their website, it should be compliant to the Zigbee 3.0 standard,
so I bought one, tried it, worked flawlessly with Home Assistant and ZHA and went to buy another 6 of them to automate all of the blinds I have in my home.

First of all, my setup:

DELL Wyse 5070 with 8GB RAM and 2 CPU
SONOFF Zigbee 3.0 USB Dongle Plus-P

Home Assistant is running in a VM on Proxmox 7.2 with 2 CPU and 4GB of RAM allocated.
Home Assistant 2022.12.8
Supervisor 2022.11.2
Operating System 9.4

So, here’s the problem:

In my home there are another 66 Zigbee devices, which are IKEA Tradfri LED2005R5,
and when I try to use the blind actuators after having paired all of my lights,
the Vimar behavior becomes very weird and unresponsive, never reporting states (blind position/status) and delaying commands sometimes even by 40+ seconds.
At the same time, IKEA bulbs become very slow to execute commands (1-3 seconds).

The weird thing is that when the IKEA bulbs are not on the network, blinds work perfectly fine.

I also tried to pair all of my blinds and then progressively adding my bulbs, and as expected, as I pair them the blinds become progressively problematic.

The workaround I used at the moment is moving all of my bulbs on Zigbee2MQTT and using a Sonoff ZBbridge flashed with Tasmota, to run all the blinds on ZHA and it works perfect (Zigbee networks are running on different channels, respectively 15 and 11).

Any help understanding what is happening and solve this issue would be very much appreciated as the proper solution would be having a single Zigbee nework.

Thanks in advance!