VirtualBox haos_ova-8.4.vdi won't boot

Running Windows 11, tried latest VirtualBox and an earlier version (6.1.30), same results.

Steps to reproduce:

  1. Download the vdi and follow the instructions here: Windows - Home Assistant
  2. Power on the VM
  3. Observe it gets stuck in a boot loop trying to load Slot A, then drops into UEFI interactive shell ad, and back to Booting slot A ad infinitum
1 Like

In case anyone else runs into this, make sure you bump the # of Processors up to 2. The default is 1 and you must switch it to 2 or the VM won’t boot.


You are GOD
Since it said ‘Recommended Minimal Settings’ in the official doc, I never thought it would be the problem

1 Like

Hi, could you help me one thing? My HA was running on VirtualBox fine with 2 cores and my CPU is 2 core (i3 6100t). I replaced the CPU to i5 6500 and set the Virtual Box to 4 core but HA won’t boot and stuck on the docker container line… if I put it back to 2 cores then works. I’m running frigate and deep stack on the HA so is really heavy.

Thank you

1 Like

Perfect - thanks for this… my instance of HA broke with this error so I reinstalled to get the same error…

this was the solution!

at least something is now up and running… now for learning about backups.

So i decided to start fresh on my HAOS and i was having this issue, BUT it wasnt too little processors, I gave it too many and got this same issue, I have a 32 core processor I gave HAOS 16 and i got this boot loop, dropped it to 4 cores and it started booting. For anyone that reads this and says well I have more than 2 processors. Too many and it wont boot either.

After going testing all of my processor core options, 6 seems to be the max. previous post was incorrect i booted on 4, kept going up til it wouldnt boot anymore, and after 6 it stopped booting, so between 2-6 is where it needs to be for virtual box.