Virtualbox won't boot anymore

Hi all,

After a reboot of my windows PC, my Home Assistant VirtualBox machine won’t boot anymore.
It get’s stuck on the ‘cmd-style window’ with the text “Autoboot-”.

During startup i can quickly see some more info of which i quickly took a screenshot.

A possible cause might be that i’ve tried to install/create a VirtualMachine in Hyper-V (tried to create a Windows VM), but i’ve already disabled all Hyper-V functionality in the ‘Turn Windows Features on and off’ dialog again.

This was a fairly new HA install, which leads to the point that i didn’t create snapshots yet (should have, i know…).
Also my ‘old’ HA VM won’t boot anymore by the way.
Really hoping to be able to ‘rescue’ the install as quite a lot of work has been put into it already. [

Hope you guys can help me out, any hints are welcome to get this thing running again!

Thanks in advance!

The output claims it can’t find the partition file/directory. Are you able to check the existence of the /efvars path it’s defining?

Thanks for your reply.
I’m not sure where i should see the path it’s looking at?
My .vdi (is that what we’re looking for? ) is at D:/HA/

Just looked a little further, more specifically it looks to be an issue with the Master Boot Record which cannot be read. I’d use your favourite search engine to see if there are some free VDI recovery tools to help rebuild it.

Failing that build a new image and explore the existing vdi to extract configs to transplant into the new VM.

I have what appears to be the same issue. I had been sucessfully using virtualbox to load Home Assistant vdi files. After a period of not using them, suddenly any attempt to reload the vdi files results in the same symptoms you found. Has this issue ever been resolved? Please enlighten me with what you tried.