VirtualBox Wont recognize Sonoff ZigBee 3.0

Hey guys! I really need your help.
I got Sonoff ZigBee 3.0 and I’m running HA as a virtual machine on a laptop with windows 10.
I added the USB into VirtualBox but it seems like I can’t see it on HA.
I added pictures here so you guys can see what I’ve done and what I’m seeing at HA.

At HA under Hardware, I can’t see anything about the USB/Sonoff ZigBee 3.0 or anything like that.
So I need help.


If so I’m running the same step up.

You might want to consider shut down the VM guest, and then change the USB to USB 2.0 (instead of 3.0 in your picture) and see if the compatibility improves.

Sidebar - may or may not be related:
Consider using USB 2.0 ports on the laptop, also an USB extension cable, and/or a (powered) USB 2.0 hub

1 Like

Interesting, why is that? I’ve been running on 3.0 (server & hub (powered)) on 3’ extension without any noticed issues.

I forgot to mention, check the Windows device manager after the VM has spun up the HA instance and see if the stick is still listed.

If so, right click on the stick, go to properties, and then Energy Management and make sure you un-tick the bit about… allow this device to be turned off.

Restart the VM.

1 Like

This specific USB dongle is by the way discussed here → ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" based on Texas Instruments CC2652P +20dBm radio MCU now sold for $14.99

Are you running Home Assistant Operating System (HA OS, formerly HASSIO) in a VM in VirtualBox? Or are you running a different Linux distribution and other type of Home Assistant installation?

Not sure if needed when running the USB port in pass-through mode to a VM in VirtualBox under Windows 10 but normally when wanting to access the adapter direct under Windows 10 you would need to install drivers:

You absolutely want to use a very long USB extension cable and not connect it to USB 3.0 ports. Read:

Another reason for using a USB extension cable is that the USB-plug design of ITead’s Sonoff Zigbee 3.0 USB Dongle Plus hardware adapter is a little short which makes it harder and sometimes impossible to plug it into some USB ports if the computer enclosure/chassis/casing is to thick around the USB-port as that will physically prevent the USB dongle from actually making a proper connection inside the USB port even if it looks like it is plugged in all the way that is possible.

So it’s really hard for me to tell you guys how I solved it, I restarted everything, then I still had the same problem, so I restarted everything again, and again, a few times more, then when I lunched the VM
I heard the sound of the USB device being disconnected and then it appears in HA.
So it is working now, No idea what solved it. But apparently, I am an IT specialist now. :smiley:

Great! Just make sure Windows doesn’t power down the stick when the VM is not running.

1 Like

All the ports on my server are 3.0 and 3.1 (all blue), I’m not running any external drives so perhaps that the reason I’ve not seen any issues… (Yet)

FYI, you can “convert” a USB 3.x port to a USB 2.0 for it by using a powered USB 2.0 hub

1 Like

Hi Guys,

I’m very new to this. Moved from ST.

I’m running a VM in VirtualBox, on Debian Linux 11. HA is up and running fine but i can’t get the Sonoff zigbee USB to show up in the USB section of the VM?

Any ideas?

Do i need to find and install Linux drivers first?


Depending on the operating system in the VM you may need to install Linux driver inside OS on the VM.

You should not need to install drivers on the OS running the hypervisor with the VM as all that should to is pass through for the USB port.

Why not try HAOS instead first if moving from SmartThings?

Using the Home Assistant Operating System will make updatin releases much easier and will make it act more like an appliance similkar to a commercial smart home hub.

Hi Hedda,

I managed to get it working. I had to intall the extension pacakge for Virtual Box and follow the insructions from there.

I’m using the PC as a media PC also, so i dont think HA os is an option really.

Thanks for your help.

It is an option for you though - you run your PC as the media server, and also run VirtualBox already. So your could easily run HAOS as your VM guest, directly under your VirtualBox. This is what Hedda meant to convey.

This likely removes overhead to the full Debian, and most likely a lot of time down the road, just to keep your Debian + HA VM everything together.

(And with HAOS as the VM guest, you would not need any extension package.)

1 Like

Exactly, I indeed meant that you should try to run “Home Assistant Operating System” in a VM as guest OS directly under your VirtualBox, there is even a pre-made image for it →

Ok guys apologies but I’m lost.

I’m running home os inside virtual box running on ubuntu. (Tried Debian and didn’t like it sorry)

I guess the bit I’m missing is the guest os setup os?

In the future, the method that always works for me is to add the USB stick in virtualbox. Then remove the stick and shut down the virtual machine. While it is off, plug the stick back in. Then start the VM.

Unclear what you mean by "home os ", you saying that running “Home Assistant Operating System”?

Please understand that the correct terminology and exact names of all stuff is very important for clarity.

Example “Home Assistant Operating System” is the “Guest OS” running inside the virtual machine:

  • Physical Computer → Ubuntu Linux → VirtualBox → VM → “Home Assistant Operating System”.
1 Like

Hi Hedda,

Yes that’s correct.

I just wasn’t aware the VM was the ‘guest’ os