Visonic MCT-340 E Window/Door Sensor

Using #Nortek/GoControl Z-Wave & Zigbee USB Adapter HUSBZB-1
to control Zigbee devices.

Got the Visonic MCT-340 E paired and working have 2 sensors on the panel
one that shows open or closed status and one that shows F for temp but nothing
in the box for the temp.

Has anyone figured out how to get the temp to show?

I have four of these sensors and I’ve added them through the ZHA component. Only the very first one that I added shows both the binary sensor, for open/close, and temperature sensor with values. The other three sensors show values for the binary sensor open/close but the temperature always shows up as unknown.

I have tried multiple attempts of re-adding the sensors. I’ve also tried resetting the sensor then putting ZHA discovery on, and the reverse with discovery on and then resetting the sensor. I’ve tried triggering the sensor while discovery is on. I’ve tried drastic temperature changes with dicovery on, aka blowing hot air across the sensor. None of which have caused temperature values to be found.

So, yes, I did get one to work but I couldn’t tell you how. Hopefully we can figure something out.

I noticed a name difference between my sensors. All three that are not working are 0b237 and the working one is 0b239. Your sensors that do not work, what do their names look like? I’m hoping it’s more than a coincidence.

I had issues with pairing these as well. Eventually got it to work by factory resetting and resetting HASS. I also had a lot of issues with incorrect position. For example, I would open a window I had a Visonic sensor on. HASS reported open. Then after about 5-10 minutes, HASS would show closed. If I closed and reopened thew window, it would show open, then again show close awhile later. Completely opposite of the problem you would expect. I believe 3 out of 4 showed temperature sensors for me but took forever to update.

I ended up moving these back to SmartThings and using them via the MQTT bridge.

I understand that 2.4 GHz devices like Zigbee have less object penetrating power compared to ~900MHz devices like Z-Wave and wondered if that could be a contributing factor in the behavior you guys are seeing. Mostly I think that would be a problem with messages being delayed or not received. Zigbee has an acknowledgement protocol that might allow a device unsuccessful in it’s first few attempts to send out it’s message again until it finally gets through when conditions are just right. (Looking mainly at what @gregg098 described)

I’m looking to buy some of these sensors as they are currently $10 which is an amazing price for a door sensor even if the temperature function isn’t quite working right. I am most worried about the the open/close status being unreliable. I’m wondering what differences in setup could be causing some of these issues.

For anyone using these (or other Zigbee sensors) on HASS here are a few questions to compare:
How far is your sensor from your Zigbee stick? Are either the stick or sensor near Wi-Fi devices also transmitting at 2.4GHz? Are there a lot of walls or obstructions between them? Did you initially pair it next to your hub or at it’s final location (possibly causing it to configure with a lower transmission power than needed)?

Anyway, I hope you have a second to answer some questions. I really would love to see this device work in my setup.

For me, the Visonic sensors were scattered throughout my house. They mostly paired OK from the window or door I had them on. In fact, the closest one gave me the most trouble. Other ST branded sensors were pretty far away and worked OK when paired with HASS.

Paired on SmartThings (where they are now because of issues), I have had zero reliability issues for the last month or so.

Its very possible there are interference issues that I can’t avoid the way my setup is although it was never an issue before. I have everything in my hall closet’s top shelf. Cable modem, router, switch, NAS, Rpi with HASS and Z wave stick, SmartThings hub, Ooma hub, and a UPS.

For what its worth, I had a period of months while migrating to HASS where there were two Z wave networks coexisting side by side (ST and HASS). No issues with either in terms of reliability. I understand they are different frequencies than Zigbee, wifi, etc. Just stating an observance. I am finally Z wave free on ST and have the radio disabled. I only use ST for Zigbee at the moment.

Those are my random thoughts. Hopefully useful.

1 Like

I am also received “unknown” in the temperature sensors on these devices. Has there been any progress figuring out why some are able to push data and some report unknown?

Would love to see temps and battery levels.

Absolutely do-able: https://gist.githubusercontent.com/tylerlange/551578d52938dc38efa3147f3ae4ab7a/raw/3e8601f66bf5f6183022158e39b1ed20360ea87d/gistfile1.txt

Originally only the first one showed the temperature. I pressed the tamper switch a few times and the temps started showing for my other sensors.

Temp is now working great on these.

Any progress on Battery Level?

Also when the Temp displays in a sensor it looks like the value
is not rounded sometimes it will show long values like 82.45176
which just looks weird in the sensor window, but glad to have the Temp.

Could someone please guide me on how they managed to get the temperature reporting on these devices to start working?
I tried the tamper switch option on multiple sensors I own and none of them started reporting the temperature :frowning:
I am on the latest version of Hassio, if that matters.

I have 4 MCT-340 E sensors that for the longest time only 2 were showing the temperature until someone suggested removing and reinserting the battery which I did and suddenly the other 2 starting displaying the temp. I would try this if you haven’t and restarting HA. Hopefully it works for you.

1 Like

I did try removing and resinserting the battery as well as restarting HA. All my sensors still report 32F as the
fixed temperature no matter what I do :frowning:
The ‘press the tamper switch multiple times’ approach didn’t help either.

Is there a custom component available for this sensor which makes the temperature work more reliably?

There is no custom component that I am aware of. As mentioned, mine for the longest time wouldn’t report temp in two of them and after removing and replacing the battery they finally decided to start working. I believe there were updates to the zha/bellows config a few months back maybe that helped my situation.

Sounds like yours are reporting a temp but it’s incorrect. Is the 32F what is showing when you go to the States “<>” page ? Not really sure why that would be showing or how to change it.

Thanks for the feedback. I’ll keep trying this method too.
As for your query, for me, the sensors started showing 32F right since the moment they were added. The value hasn’t changed since. Even worse, if I change that value via a service call, it stays at the new value without ever getting updated back to 32F (in essence, nothing every updates this sensor automatically).

If it helps, this is the only line I see in the debug log, where the temperature is reported.

2018-08-01 19:53:49 INFO (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=sensor.visonic_mct340_e_0b11d7bb_1_1026, old_state=None, new_state=<state sensor.visonic_mct340_e_0b11d7bb_1_1026=32.0; friendly_name=Visonic MCT-340 E, unit_of_measurement=°F @ 2018-08-01T19:53:49.618305-05:00>>

I’ve the same behavior as @ajayjohn - temperatures from all of my MCT-340 Es report a static temperature. This has been the case since whatever version homeassistant was at in 2018-06 up until 0.73.1. FWIW here’s all the homeassistant versions that this has applied to. Running HA with docker:

0.73.1       
0.72.1       
0.70.1       
0.69.1       
0.68.0       
0.67.1       
0.67.0       
0.66.0 

Look at the min/max/current values in the image above - no change as long as I’ve had metrics.

I’m upgrading to 0.75.2 now and I’ll try to re-seat the batteries in a couple of them.

edit: no change after upgrading to 0.75.2 and re-seating the battery in 3 of the 5, and completely re-pairing the other 2 (remove battery, hold tamper switch, re-insert battery, and call zha.permit again)

I suspect the datapoints only correspond to HA restarts

2 Likes

I am seeing the static 32.0F as well, running 0.76.2…

Since this is a common issue, I guess it may be worth reporting it at https://github.com/home-assistant/home-assistant/issues

Hope to create an entry, once I am back home (traveling at the moment). If anyone else gets to it before me, then please go ahead and raise an issue.

open a issue

https://github.com/home-assistant/home-assistant/issues/16632