Visonic Powermax and Powermaster Component

If you can’t work out how to bypass (not arm) sensors using your panel then try calling the HA service.
In the HA frontend

  • Go to Developer Tools
  • Select Services in the top blue bar
  • In the Service selection, click the down arrow and select visonic.alarm_sensor_bypass
  • In the Entity selection, select your sensor that you want to bypass, for example binary_sensor.visonic_z01
  • In the service data box, add a 2nd line like this bypass: True

An example is here

You can then check that you sensor is bypassed by looking at the sensor details in HA


As you can see it says ‘device armed’ is False

To put it back set bypass: False and call the service again

Give it a try first :wink:

I’ve been looking at the list of sensors and I don’t have the PIR, Smoke or Flood sensors. If you can set the logger to debug for this integration (like this) and copy and post here the text that looks like this from your log file

Also tell me which sensors are which i.e Zone 2 is a PIR Next K9 etc etc

EDIT: Instead of the above, it might say [Process Settings] Found unknown sensor type. Can you tell me that as well please

Thanks :smile:

Ok, i will do that. I have little holidays in two weeks…
It will be with pleasure.

Thanks again


Is it possible that this integration will change the code of my PowerMax Pro?

I tried with a USR-TCP232-302 box, without success after a day of testing I have only errors. And tonight I see that my installer code doesn’t work anymore. And I don’t think we can get it back.

Tomorrow I will try to connect it with esp…

The only way to change any of the codes is to write to the EEPROM in the panel. I have this permanently disabled in the code so I know that it is impossible for the integration to change anything in the panel. I know that visonic integrations on other platforms allow you to change EEPROM settings but I do not.

Does the USR-TCP232-302 have TTL or proper +/- 12 volts RS232 voltage levels? You need a device with TTL voltage levels for it to work. If you need any help getting setup then please post your issues here and good luck.

I don’t know how it could have happened. So I find myself with an alarm integrated to HA, but I don’t have the code anymore…

I’ve never been able to get the USR-TCP232-302 to work, so it’s going to go back to where it came from…

On the other hand it works with ESP Link, it gave me a little trouble to understand because I was not very familiar with it, but it’s ok !

Congratulations again for this job !

My work in french :

So I can tell you this as it is downloaded from your panel’s EEPROM but not used.
If you uncomment lines 2322 to 2326 in the file (remove the ‘#’) , set the logger setting to debug and then look at your log file for [Process Settings] Installer Code you will see your installer code.

Not simple tonight I have a heavy head… But thanks, I’ll watch !!!
But I’m very happy because it works perfectly and I’ve been waiting for this for a long time!

I need to arm different zones. ie. zone 1, zone 2, zone 3.
Is this possible?

Do you mean partitions or individual zone sensors.

The integration assumes a single partition and does not have support for multiple partitions.

You can arm/bypass individual zone sensors but only by using an HA service (using a script or automation). See visonic.alarm_sensor_bypass on the wiki here. You can test it from the developer tools in HA using the service. If you have more questions about its operation then ask here :smile:

Hello Dave,
thanks for your quickly answer.
I just tested it today, and it work fine, partial and full mode appear automatically.
Thanks a lot for all your work!

I noticed that after a while (24/48 h) I lose the sensors, but the panel remains functional…

I can only know what has happened if you can upload your log file to pastebin, dropbox or tinyupload and post a link in this thread. Remember to set your logger settings as per the instructions on the wiki here

I have the Visonic integration notifying me via Telegram when alarm is armed, unarmed and tripped.
Last night at 2am (time when when clocks went back) I got Telegram disarm notifications every minute for six hours. They stopped at 8am.
Can anyone explain why this might of happened? It seems most odd.

For me I received a notification on Event 9 (“Watchdog timeout, going to try to get a better mode”) at 1am.
I also suspect something about the winter time (either in the Visonic Panel or the Home Assistant server).

Can’t be the panel! I’ve realised I’ve not reset the time since doing a reset of the ethernet module a week or two ago.
All very odd as the Arm/Disarm notifications via Telegram have stopped since I updated everything yet the test scripts I set up are working OK.

Sent by private message

Hello Dave,

I have no information [Process Settings] in my logs, i have these informations :

2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic] =============================================== Display Status ===============================================
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]      key 0  Sensor id=1  dname=Z01  stype=None zname=Basement       ztypeName=Voie Périp ztamper=0  ztrip=0  bypass=0  lowbatt=0  status=0  tamper=0  enrolled=1  triggered=0 
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]      key 1  Sensor id=2  dname=Z02  stype=None zname=Kitchen        ztypeName=Temporisée ztamper=0  ztrip=0  bypass=0  lowbatt=0  status=0  tamper=0  enrolled=1  triggered=0 
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]      key 2  Sensor id=3  dname=Z03  stype=None zname=Kitchen        ztypeName=Incendie   ztamper=0  ztrip=0  bypass=0  lowbatt=0  status=0  tamper=0  enrolled=1  triggered=0 
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]      key 3  Sensor id=4  dname=Z04  stype=None zname=Basement       ztypeName=Inondation ztamper=0  ztrip=0  bypass=0  lowbatt=0  status=0  tamper=0  enrolled=1  triggered=0 
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]    Model Unknown                PowerMaster No                     LastEvent None                   Ready   Yes          
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic]    Mode  Standard               Status      Armé Total             Armed     Yes                    Trouble None              AlarmStatus None        
2020-10-26 20:06:14 INFO (MainThread) [custom_components.visonic.pyvisonic] ==============================================================================================================

cat home-assistant.log |grep Process

give me nothing …


Maybe a stupid question, i have read the install manual. But i don’t get it (beginner with HA). I have a powermax Pro with a serial2USB adapeter (RS232) attached, worked with Vera.
Can i use this or not? I see Ethernet and USB option in the manual, but the USB option says:(You do not need the Visonic RS-232 Adaptor Kit if you use a USB interface).

I see that you are in Standard Mode and you do not get the EEPROM data from the panel so you do not get the full sensor data and do not see the Process Settings messages in the log file.

Do you get

[handle_MsgTypeA6] Packet = <data>


[handle_MsgTypeA3] Packet = <data>

If so then show me that block of lines for each of the 4 sensors please. If not then I’m not sure what’s going on.