Visonic Powermax and Powermaster Component


#1

Hi Everyone,

I’ve put together a Component for the Visonic Powermax / Powermaster Alarm Systems. It doesn’t do everything at the moment so please be gentle with me as it’s my first adventure in to Home Assistant python.

You’ll find it here
Visonic Component

Installation is simple, download a zipped version from Github and unzip it in to your custom_components directory. If you don’t already have a custom_components directory then create one in your config directory (where your configuration.yaml file is).

You’ll need to put some stuff in to your configuration.yaml file too, see the example I put in the description on github. You’ll also need a physical connection to the panel itself remember.

Have fun and I’m sure you’ll let me have some feedback :wink:


Visonic Powermax alarm integration for Home Assistant
How do I remove an Entity?
#2

Tnx! I am going tot give this a try! Been wating very long for this solution. I have a (dual) RS-232 Interface Module installed in my panel right now, i believe this could work also with a rs232 to ethernet module??

Did you actually used the adapter kit? It is kind of expensive…what rs232 to ethernet converter did you use? Any cabling issues we should know about?


#3

For the hardware connection I use one of these:
http://www.tcp232.net/uart-to-wifi-ethernet-module

Although it might be tricky to get now, I bought it a long time ago. They are available wired and now wifi too.

I don’t have any cabling issues, the module is inside the alarm and is powered from the 3.75 volt supply and the RS232 is TTL and not +/-12 volts.


#4

I’ve just updated the files on Github with my latest versions.


#5

I ordered the ttl to ethernet converter. Will probably take some time to arrive, I’ll let you know how it works out…


#6

Hi

I have tried the component, but I cant’t get it running. The error message says “visonic component can’t be found” I have copied your example to my configuration.yaml and put all the files under custom_components/visonic/
I have made a hello world example under custom_components and it works fine, so the path should be OK.

Any ideas how to solve the issue?


#7

You say that you have put the files under “custom_components/visonic”, they should just be under “custom_components” without the sub directory i.e. visonic.py and pyvisonic.py are in custom_components.

Give it a try and let me know


#8

OK, keep us updated when you receive it


#9

I deleted the subfolder “visonic” and put all the files directly under custom_components, but still I recieve error message:

Component not found: visonic
09:54 components/init.py (ERROR)

Unable to find component visonic
09:54 loader.py (ERROR)

From my configuration.yaml:
image


#10

The error you are getting is an HA error, in that it can’t find the visonic python code.

I’m at a loss that something that should be so simple just isn’t. Can you check the indentation in the configuration.yaml file (although your screenshot looks OK) and in notepad++ check that there are no rogue characters in there.

Can you also check that you have installed the python libraries that visonic uses as indicated on the github page. Also remember that if you run HA in something like docker (like I do) then you need to install these libraries inside the docker image.

You could also get more debug info that might give you more of a clue by setting “default: debug” for the logger component in your configuration.yaml file, but this could make your home-assistant.log file really big so don’t leave it like this.

Other things, like is you version of python and HA up to date? Also the custom_components folder must be in the HA configuration directory (where all the yaml files reside)

Let me know if you get more info and I will keep looking in to the problem


#11

Mhh…I’m running Hassio right now, so no possibility to install python libraries. I am assuming that Hassio itself will install the required libraries on its own, when it sees the component needs them, correct?


#12

Ah that helps. I haven’t included the “Requirements” statement in the plugin yet as I was still testing it, it does say that on the web site :wink:

If you want to try it, without me altering it and uploading to github, add this in the visonic.py the one in custom_components. Anywhere near the top should do it.

REQUIREMENTS = [‘pyserial’, ‘pyserial_asyncio’, ‘datetime’]


#13

I installed Hass.io again and installed the addon again. With the requirement line there is no errors. I can see there is some kind of communication to my Powermax Complete, beause the panel says OK instead of communication fail. But I am m not able to arm/disarm, nothing happends when I press the buttons in the addon. How can I check next thing?


#14

I’m assuming that you’ve connected to your panel successfully, do you get the sensors showing up in the HA frontend and a switch showing the internal alarm parameters when you click on it? I’m also assuming that you still have allow_remote_arm set to yes?

It should look something like mine here…
alarmstuff1

The “T” on Zone 3 shows that it’s been tripped. I assume that when you click on the left most icon you get a dialog box asking you to arm home or arm away? Is this what you are doing?

Are you connecting in powerlink mode?
Have you looked at your home-assistant.log and search for visonic, is there anything that can give a clue as to what is happening?

In your configuration.yaml file in the visonic bit you could try overriding the pin code by adding this override_code: ‘1234’ # your panel user code

Let me know and if anything looks suspicious in the log file then copy the segment here


#15

Also, you could try setting these in your configuration.yaml file. This will print lots of visonic related debug data in to your log file so don’t leave them like this permanently but it will let me know what is happening.

alarmstuff2

Most of the other log file entries will be “critical” only so most of it will be visonic related. You can set each one to “debug”, “info” or “critical”


#16

It says “disconnected” for the switch “Visonic Alarm” there is no door/motion sensors showing up either.
I still have allow_remote_arm set to yes and I have set override_code: ‘XXXX’. But somehow it identifies my Visonic Panel:

Can this help? (logger in configuration.yaml for hass.io needs another type of setup)
Error doing job: Exception in callback <bound method SerialTransport._read_ready of SerialTransport(<uvloop.Loop running=True closed=False debug=False>, <custom_components.pyvisonic.VisonicProtocol object at 0x7f8daf7898>, Serial<id=0x7f8d9b54a8, open=True>(port=’/dev/ttyUSB0’, baudrate=9600, bytesize=8, parity=‘N’, stopbits=1, timeout=0, xonxoff=False, rtscts=False, dsrdtr=False))>
08:55 custom_components/pyvisonic.py (ERROR)


#17

I changed to force_standard: ‘yes’ and now I can see my sensors. If I change it back to ‘no’ the sensors is not displaying.

I still can’t arm away/disarm and the information says “unknown” for Model - Should say “Powermax Complete Part” as above pic.

(Note I am using serial connection)


#18

OK, so I can see that the Mode is “Download”. Does it ever change from Download? It should either go to Powerlink or Standard. When you force it to Standard then the Mode will go straight to “Standard”. When you force Standard or it goes in to Standard after failing to get in to Powerlink, then you get very little information from the panel. That is why in Standard you do not get the model name etc.

When you force Standard and you can see your sensors, do the sensors trigger “T” or change to open “O” as they are triggered?

When in Standard Mode, if you click on the left most sensor (Visonic Alarm) as in my screen grab earlier with “Disarm” and a bell icon, I assume that is what you are using to try to arm/disarm?
Like this
alarmstuff3

As a final thought, I would need the home-assistant.log file information to get much further, I’m more than willing to take a look through if you could upload it, even just the starting fragment is it’s too large (or you can zip it).


#19

I forgot to ask you, are you connecting using Ethernet or USB/RS232?
By the exception you stated in your earlier post, it looks like USB/RS232. This is not something that has been tested much, although it should work the same way as my Ethernet, just through a different device.


#20

No it dosen’t change from Download. Only when I set force_standard to ‘yes’ the mode says Standard (of course)

When I change back to force_standard to ‘no’ then it says Download forever.

In standard mode (when I see my sensors) I have tested now and if I open my front door for example the sensor is tripped.

Correct I try to Arm Away as in same picture as you are in, but nothing happend except a message says alarm_arm_away called.

I am using USB/RS232. (My USB to Serial-adapter (FTDI-chipet) worked fine in Openhab visonic addon, and also earlier with Visonic addon in Vera Edge).

(I had to change the file from .log to .yaml for upload)
I add the log file. Really appreciate your support/development!
home-assistant.yaml (2.9 KB)