Visonic Powermax and Powermaster Component


#81

@davesmeghead - just wanted to say “Good job” - I have not yet gotten to the point of trying this plugin out. But I will certainly try within a few months. Really appreciate your work on this - I was considering ditching my Visonic to build something myself, but if this works out, it will save me a lot of hardware costs :slight_smile:

Greetings from Denmark!


#82

Hi!

Seems something is wrong with the latest version (0.81.2):

Traceback (most recent call last):
File “/opt/homeassistant/lib/python3.6/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config) # type: ignore
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/root/.homeassistant/custom_components/visonic.py”, line 248, in setup
discovery.load_platform(hass, “switch”, DOMAIN)
TypeError: load_platform() missing 2 required positional arguments: ‘discovered’ and ‘hass_config’

Any advice?

Regards,
Carlos


#83

Ok, this one was easy :wink:

This merge brakes the custom module: https://github.com/home-assistant/home-assistant/pull/17952
New mandatory parameters. Solution was easy, just modify visonic.py and add the two last parameters (empty dictionary and config). Restart and sensors will work again.

visonic.py:145: discovery.load_platform(hass, “sensor”, DOMAIN, {}, base_config)
visonic.py:168: discovery.load_platform(hass, “switch”, DOMAIN, {}, base_config)
visonic.py:169: discovery.load_platform(hass, “alarm_control_panel”, DOMAIN, {}, base_config)
visonic.py:248: discovery.load_platform(hass, “switch”, DOMAIN, {}, base_config)
visonic.py:249: discovery.load_platform(hass, “alarm_control_panel”, DOMAIN, {}, base_config)

Regards


#85

Hi,

First I’d like to thank you for your awesome work of what seems to be the most advance job on Visonic in free domestic world !

I’ve just set up a cheap (and simplest?) solution for serial coms.
I’ve successfully setup wireless communication to my Visonic powermax pro using a 7$ ESP32 dev board(Arduino compatible w/ WIFI) with the official WiFiTelnetToSerial sketch.
Not tried but sould work as well with a 4$ ESP8266 dev boards…

I’m using standard mode as I haven’t succeed the power link mode yet.


#86

Thanks for figuring this one out…i just noticed the break too. This component has become the most valuable component in my entire setup…

Will try this asap.

edit: OK, where should they be added?
edit 2: nevermind: already found them…was looking for wrong strings.


#87

Working now?


#88

Yes! Working again…


#89

Hi,

I’ve just created a pull request for a bugfix that corrects a new mandatory parameter.

Please check it.

Regards,
Carlos


#90

Sorry but I missed all the excitement of an update while I was on holiday, I just got back last night. I’ve merged your pull request so all should be good now!


#91

Great!

Thanks :slight_smile:


#92

Muchas gracias!!!

Thank you very much. I was thinking about downgrade but I could fix it with your solution.

Like for @opaulzen this is the most valuable component for me now!

By the way, I got the Amazon Echo and this is how I get working the alarm with it:

(You need to integrate Alexa in Home Assistant )
scripts.yaml

  arm_visonic:
alias: Armar Visonic
sequence:
  - service: alarm_control_panel.alarm_arm_away
    data:
      entity_id: alarm_control_panel.visonic_alarm
      code: 0000

disarm_visonic:
alias: Desarmar Visonic
sequence:
- service: alarm_control_panel.alarm_disarm
data:
entity_id: alarm_control_panel.visonic_alarm
code: 0000

The you have to create a routine on Alexa app: If I say X, then trigger this ambient.

Best regards!


#93

Hi, seems like a good component and exactly what I have been looking for. However I use Hass.io. How do I install this? Since install via command line is not possible in hass.io.


#94

Access the file system with SAMBA add-in. Create a ‘custom_components’ folder in the config directory. Copy the files, including the sub-folders into custom_components folder.
Once you set up the serial/IP connection and set the configuration.yaml entries and restart it just works.

I was very impressed!

Mark


#95

Ok, thanks for the answer.

How do I “set up the serial/IP connection”? The system have been hooked up on PowerLink2 for several of years, anything else I have to do?

How do I know that port number to use? I have the correct IP adress in configiration,yaml:
visonic:
device:
type: ethernet
host: ‘192.168.1.126’
port: 10628
motion_off: 120
language: ‘EN’
force_standard: ‘no’
sync_time: ‘yes’
# allow_remote_arm: ‘yes’
# allow_remote_disarm: ‘yes’
override_code: ‘0000’
# arm_without_usercode: ‘yes’

Some screen shots from the switch and panel. I am pressy sure that something is not working : )
Any ideas?

image


#96

I used a WIFI to RS232 gateway. You have to remove the PowerLink2 and replace it with a device that HA can use to communicate with Visionic, using the same plug that the PowerLink2.

https://www.usriot.com/products/serial-uart-wifi-module.html

One of these fits in the back of the alarm panel. I purchased a 10 pack of jumper wires ( like individual ribbon cables) and used 6 to connect the wifi module to the powerlink plug (connection covered above)

You don’t need to get the wifi version, the wired will work as well and may be easier to configure.


#97

Ok, then I think I am stuck, since I need to keep the PowerLink2 to reach the external server I use for Visonic-Go mobile app.
Thanks


#98

I gave up trying to get the data out via the PowerLink2 module.
It returns a variable list of XML and i couldn’t wrap my brain around processing it consistently.
Python has so features that helped. Even if i could solve that, then there is getting it into HA.


#99

Ok, I understand, Thanks for your time.


#100

Sorry - tried to read through but couldn’t find - what hardware is needed for this?
I am a bit of a noobie… can someone post a link to the component needed on eBay or so please?


#101

This is an easy question, and welcome. In the first post at the top of the thread there’s a link to the component on Github. If you scroll down there’s a description of the hardware needed for this component to work.
The link is here