VMWare Image - why isn't it working from start? No network, no docs?

Hi,

Downloaded the VMWare image yesterday. One little readme of how to set up VM Workstation for the image had been nice. Yeah, I found the info on google - but why make things harder than they should be?

Next hurdle, can’t get any IP working. Tried both bridged and NAT from VM Workstation 15 Pro - no go. Since HassOS isn’t a known entity for me, it is hard to get “hacking”.

I have used the nmcli con edit approach trying to set a static IP adress.

I have also used VI to edit the default configuration file under /etc/Networkmanager/System-Connections. Still no go

If I run a windows box under the same VMWare installation, all is good.

Since I get no network up and running, I can’t use WCP or SSH

Please, what am I missing?

I have a Win 10 Enterprise as host, with an Intel NIC

// Lazze

I am not in front of mine now, but in vmware you need to set the virtual network card to an intel one (I think) -I’ll post again when I get to it.

Bridged is correct.

Hi,

Thanks for replying!

I have set VMNET0 (bridged) to my internal NIC Intel i210 using the VMWare Network Editor.

Still no luck

What I can see it just starts 2 docker-containers, so it shouldn’t be to hard to just run those container under a real OS :slight_smile:

// Lazze

Hi,

Found this:

This is how I solved it to run in VMware Workstation 15, but probably works also with 14.

  1. Create new virtual maschine (custom)
  2. Select “Windows 10 x64” as operating system
  3. Firmware Type --> UEFI (without secure boot)
  4. SCSI Controller --> LSI Logic SAS
  5. Virtual disk type --> SATA
  6. When importing the vmdk, do not choose “convert”, just add it.

And strangely enough, selecting Win 10 x64 as OS does make the NIC work!

// Lazze

My method for networking was to click in the advanced arrow and change Adapter Type to Intel PRO/1000 MT Server (825454EM) - the default did not work.

Thanks this helped…

Rich

1 Like

This helps with all of me network problems.
Tnx