Voice performance with INTEL N100

i have the latest version of HA running on INTEL N100 8GB RAM end work great.

I’m trying ASSIST feature with voice assistant, and I have installed:


Configuraed in Italian language, and I have tried small and base model, voice to text work but it’s usable, it’s very very unprecise. I have tested the same result in English language.

I wolud like to know if it’s normale with my hardware or I need to tune some setting in my configuration?


I am also using a intell n100 with 8 gigs, a beelink box.

Today I started playing with the m5stack for the first time.

It seems to work “ok” in english, but can’t seem to get it to work with spanish. To get it to work in english was a bit tricky since most of my devices are named in spanish so I had to set up aliases in english for them.

In spanish I pretty much just get “I didn’t understand what you said” for everything.

I ended up setting up two voice assistants, one in english and one in spanish. On the add on configuration for whisper and piper I put in spanish as main language, but spanish voice assistant doesn’t work, but the english one works fine even though whisper and piper are set up to spanish.

When I type on the assistant in spanish it doesn’t seem to work either. In fact if I turn on my “cueva” light manually, I can type in assistant “apagar cueva” and it turns it off, but if I type “enciende cueva” it tells me it doesn’t understand.

I tried the assist via the HA app, and similar results, if I type “apaga cueva” it does turn it off, but if I type “enciende cueva” or “encender cueva” it tells me it doesn’t undestand. And on the HA app if I try to speak “apaga cueva” if I speak very very clearly it does it correctly. When I say “enciende cueva” it types it correctly, but the response is that it doesn’t undestand.

I am guessing the non english languages are still in very very beta. I was trying to google in spanish to see if I could find anyone that had good results in spanish but didn’t seem to find anything, just tutorials on how to set it up in spanish.


You can try Vosk addon instead of Whisper ( work great with non-english language)

Just gave it a try, and I am getting similar results. If I say “Ok Nabu apaga cueva” it does turn off the light called “cueva”. However when I say “Ok Nabu enciende cueva” it says it doesn’t understand.

With whisper I get pretty much same result, except vosk does seem to understand “apaga cueva” better than whisper.

i have tried Vosk and work much better than Whisper with Italian language

1 Like