VSCode Search results

Is anyone else having an issue with Search in VSCode since the upgrade to version 1.72.0?

I know this isn’t specifically an HA issue but it is only the HA config folder I am having a problem with.

Update: It is definitely a VSCode issue. I downgraded to the August 2022 (version 1.71) and all works again.
Quite why it only affects the AH config folder is a mystery though…

Any suggestions gratefully received.

Please don’t suggest I raise an issue with VSCode. I have no idea how to describe this issue in a way that would make any sense outside of the HA environment!

I’m using a standalone install of VSCode on my PC and global search returns ‘No results found’.

It does however work when searching another folder on a NAS
It also works on a local folder.

Here is a search on HA config (no results)


Here is a local folder search


Just tested search in latest VS code on a Windows box with network folders, local folders, mapped drives. No issues. Just curious, have you actually checked the .gitignore file to see if there is anything there that might be blocking your search results? No idea why that would change with VSCode versions though.

Also have you tried disabling any extensions? Maybe one of them might be causing an issue?

Yeah, I went through all that. also did the obligatory restart of my PC and my HA machine. Even uninstalled and reinstalled VSC.

After I originally posted here I tried on my laptop and it worked which got me thinking about versions of VSC.

It’s a bit of a mystery. I’ve turned off automatic updates for new. :man_shrugging:

also experiencing this as of yesterday… downgrading to August release fixed it. I’m accessing my HASS config via Samba share. This was the only post I could find with anything similar so you are not alone!