Wait until Kernel Time Synchronized Error on first Installation

Hi,
I’m totally new to HA, and trying to install it its becoming a nightmare.
I’m using a Raspberry Pi 4B and a 64gb Sandisk Extreme microSD card. I’ve followed the steps, using Balena Etcher to flash the HA image (tried v.6.6, both 64 and 32 bits - and v6.2 64 bits I found on Github). I’ve tried with the USB stick CONFIG/network/my-network file…no luck
It’s always the same point where it gets stuck, 'A start job is running for Wait Until Kernel Time Synchronized (1min 28s/1min 30s). It runs out of time and gives a FAIL on the left (instead of an OK). It keeps on loading and I’m able to see the ‘Preparing Home Assistant (this can take up to 20 minutes)’ but stays in there forever.
Connecting the Rasp. to a screen it seems to be working though, the ‘ha >’ in green waiting for a command is okay. It also shows a free IPv4 adress (192.168.1.135/24).

ANY hints??
Gratefull in advance

Thanks for the quick answer, means a lot to have some guidance.

I’ve tried with the following:
ha > dns options —servers dns://8.8.8.8 —servers dns://8.8.4.4 —servers dns://1.1.1.1 —servers dns://192.168.1.22
ha > dns restart

No luck, I restarted the Rasp. and same, FAILED on the Wait until Kernel Time Synchronized (1min 30s) and is hanging in Preparing Home Assistant (20min) forever.

Any other hints?

Thanks

Hello, I have the same issue on my Pi 3A and on my VMWare install of HA… I really don’t know why this is happaning, I think it has a hard time resolving DNS requests but idk why.

Hi! I think the problem resides in the NTP servers you have.
Try doing the following:

At the ha cli type login
Then type vi /etc/systemd/timesyncd.conf
Press i
add the line NTP=time1.google.com time2.google.com time3.google.com
and change the FallbackNTP to FallbackNTP=0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org
Press ESC and type :wq
Type reboot