Wake on LAN to public IP (office PC)


I am trying to send a magic package to my office PC which is behind a static public IP.
I have enabled the PC, BIOS, LAN Card, Windows and router, and got WOL to work with Team Viewer from home.
Now I want to get WOL or WOL Switch to work from my home HA to make an automation, as HA already knows that I am parking my car at work (google maps location).

  - platform: wake_on_lan
    mac_address: "mac address"
    name: "Awesome pc"
    broadcast_address: "publicIP:forwardWOLport"

Does anyone have this working?
Thanks in advance!

edit 2019-01-08 12:13:
The error I get:

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/service.py", line 277, in _handle_service_platform_call
    await getattr(entity, func)(**data)
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/switch/wake_on_lan.py", line 81, in turn_on
    self._mac_address, ip_address=self._broadcast_address)
  File "/usr/local/lib/python3.6/site-packages/wakeonlan.py", line 79, in send_magic_packet
    sock.connect((ip, port))
socket.gaierror: [Errno -2] Name does not resolve


I got it working.
I added “wake_on_lan:” to my configuration.yaml and removed the port from the broadcast_address.
Not sure if the “wake_on_lan:” in the configuration.yaml is necessary, it is not in the documentation.

currently in the configuration.yaml:


  - platform: wake_on_lan
    mac_address: "mac address"
    name: "Awesome pc"
    broadcast_address: "publicIP"

 - alias: turn on workpc
     platform: state
     entity_id: device_tracker.google_maps_xxx
     to: 'office'
     - service: switch.turn_on
       entity_id: switch.Awesome_pc