Wall Mount With iPad 2?

I have an old iPad 2 laying around that I’m trying to repurpose into a wall-mounted dashboard. I recently restored (wiped) the iPad and brought up Safari to see what my Lovelace dashboard would look like on my tablet.

However, when I open up Safari and navigate to my UI, I only see the top blue Home Assistant bar and the rest of the page is blank white

The iPad is running Safari 9 and unfortunately I can’t install any other browsers through the App Store because I’m running iOS 9.3 (the latest version that this device can run) which is incompatible with all of the current browser app versions.

Is anyone else using an iPad 2 to access the Home Assistant UI, or does anyone have an idea about what might be causing this? I’m assuming that it’s because the browser is way too old but I could be wrong.

I just need to know if I can fix this or if I need to get a newer tablet to do a wall mount :disappointed:

It is!
I have seen topics in the forum that used workarounds like using another UI (HADashboard, Tileboard, …), or show the UI from a remote device with a VNC app.

Thanks for confirming that for me! I’ve used HADashboard in the past but I could never get things looking as good as I wanted them to look. Just glanced at Tileboard and I like the look of that one better out of the box. I think I’ll give that one a shot and then fall back on HADashboard if I fail.

Thanks again!

“show the UI from a remote device” awesome idea :slight_smile:
have you already try this solution ?

This is a VNC option and works for me. Scrolling on the remote browser is tedious, but if you have small lovelace pages without many entities, it should work just fine.

1 Like

i thinks it could be optimise to :

  • force the VNC app in fullscreen :DONE
  • force VNC server to render the exact ipad resolution. : DONE

works amasing well !!!


Couldn’t get the VNC browser to run on my Pi. I just tried setting up TileBoard which worked fine on my computer but on my old iPad I couldn’t get past the Home Assistant auth screen (the login form didn’t show and it just said “initializing”. I’m assuming this is also because my browser isn’t compatible).

I’m devising a plan to run a different web server on my Pi that exposes TileBoard locally so that I can use a long-lived API token to authenticate with Home Assistant to bypass the auth screen on my tablet.

Needs to be a separate web server because my Home Assistant instance is exposed via HA Cloud :sweat:

here my command :

sudo docker run -d -e VNC_SCREEN_SIZE=1024x768 --name chromeProfile -p MY_LOCAL_IP:5900:5900 siomiz/chrome

The issue is “(the login form didn’t show and it just said “initializing””, i just want the app to load in order to push Ipad sensors.
Any idea for manualy forging the auth request ?


I setup the docker image from urielch/chrome-vnc on my HA machine with the following settings:

docker run -d --rm -p 6200:5900 -e EXTRA_CHROME_OPTION="–lang=de-DE,de" -e X11_W=768 -e X11_H=1024 -e URL=HomeAssistantIPAddress:8123 --name chrome-ubu urielch/chrome-vnc:ubuntu

This one can run on a Raspberry Pi (mine is a RPi4 8 GB).

I had problems with the suggested ports 5900:5900, so I changed them to 6200:5900.

Now I can logon with my old iPad 2 via VNCviewer to HomeAssistantIPAddress:6200.

Select touch pad as mouse.

The only problem I have is that I cannot push chromium into full screen mode. I always see the header of the browser.
Maybe some of you have a workaround for that.


Do you mind sharing your solution? Like which vnc app, on what platform etc?

I have exactly the same issue. Do you mind sharing what you ended up doing?

I ended up serving Tileboard with a separate Docker container on the same machine that runs my Home Assistant (I run HA in Docker as well) using the httpd Docker image.

In the configuration file for Tileboard, I use a long-lived API token from Home Assistant, but this is okay because my Tileboard instance running in my httpd container is only accessible on my local network, not exposed through HA Cloud. This allows me to bypass the HA auth screen that I couldn’t get to work.

One thing I still haven’t been able to figure out is how to get video streaming to work on the tablet. I’d like to be able to stream a camera feed from the tablet, but there seems to be an issue with the browser. I can view the stream on other devices via Tileboard, like my phone, but when I bring the stream up on the tablet it doesn’t work. I’ve pretty much given up on that at this point, but if anyone reading this has any ideas for how to make video streaming work on an old Safari browser, please reply!

@puncake Hopefully that helps


I might end up going the same route. Is there any other way to bypass that authorization screen? I messed about with enabling legacy authentication and then setting it on that from the companion app on the iPad but that doesn’t work either for some reason. Anyways thanks for your answer, hope I can get this to work somehow or else it’s a waste of a perfectly good iPad. And a perfectly able machine for this job, it bugs me when software limits the use of my hardware haha.

Great idea with the chrome-vnc :slight_smile: I’ve set it up on my Raspberry Pi 4 and I can get the dashboard on my iPad 2 :slight_smile:

If you want to get into full screen mode just pop up the keyboard and find F11


i don’t know if im to stupid, but please can someone explain me, how i can set up the: urielch/chrome-vnc
docker - in portainer? so what are the stepps to edit when i try to add the container - i have portainer installed as a addon in hassio.

it would be so nice if someone can help me out here.

best regards

also trying to understand the steps here, tried the firefox way and can access it via a browser on the ipad but have the bars from the browser and then of firefox. Wondering if the chrome-vnc would look better but not managed to run it, have HA on a VM on a windows machine, does chrome-vnc need to be on a docker on the same machine?

Hi. I see your solutions about vnc browsers. What do you think about:
-nuc with some vncserver and Desktop ubuntu (with crome or good browser)+HA

  • ipad with vnc viewer and opening browser directly in Nuc (localhost:8123)

I will try if there are issues. Some time ago i did something with vncviewer but could not manage turn off/on ipad screen in some automated way. Any hints for jailbroken ipad with 9.3.5?


Guys, is there some addon avaible to run a VNC server?

hi, did you found a workaround to have fullscreen mode?

nice about the F11, did you found out how todo if also after a restart ?