Options for Lovelace on older iPad (ios 9.3.5)

Up until yesterday I was using my old iPad as a wall-mounted dashboard to control HA. Not sure what has changed by today the HA companion ios app (1.5.1) won’t show the overview screen when set to lovelace. If I select States UI it displays fine. Lovelace was previously working fine…

Does anyone have an idea how to resolve, or an alternative so that I can keep using this device.Works perfectly fine, seems a pity to bin it because current software won’t run on it…



Lovelace has semi-worked on my iPad 3 (iOS 9.3.5) using the HA Companion iOS app (1.5.1). The two things I know don’t work are the Alarm Panel where the key pad doesn’t show up and the buttons are old skeuomorphism oval buttons, and any card with custom CSS or code such as the custom animated weather forecast card I just get a “module not found”. Also some of the text and icons don’t look quite the same as in a modern browser, but they still show up. I got rid of my old groups configuration so I can’t easily use the old States UI display because it’s a mess from the frontend.

I’m also having issues with my iPad 3 since a couple of days (or since i updated hass.io).

I can login, nothing is shown there other than the sidebar.

yes. That’s because the iPad 3 is old and doesn’t support some modern browser code such as what Lovelace uses or even some custom CSS code. The only thing you can do is go to the developer page through the app and tell it to use the old states-ui and it might look better but no guarantee.

I have homeassistant up and running on a raspberry pi 3b+
I install docker on my pi & ran the image from “docker pull jlesage/firefox”

Refer https://hub.docker.com/r/jlesage/firefox

You can now go to http://your_pi_address:5800 from your ipad2.
You will get the latest firefox instance where you can open the homeassistant url on the browser.
Its clunky, but working.
FYI, i have ipad 2 running ios 9.3.5


Nice workaround! You’re right, it’s a bit clunky, but it functions.

Nice!!! Is this possible with home assistant (former hassio)?


this will work regardless of install method of HA. all this does is run a recent version of Firefox as an appliance application that you access from a screen sharing program (VNC) or a web browser on an older device. once this is running, it’s like using a web browser within a web browser.

But is it possible to tamper with the underlying resources and provision this? Sorry if this sounds stupid but I was under the impression that hassio sort of prevented the user from doing anything else but HA

This is a docker image that runs Firefox. You use docker on anything you want to create the container and run it. Then from any device, open a webpage and go to ip.addr.of.device:5800 And you then see Firefox running. Within Firefox, then go to the URL for your HA install and login as normal. All this does is allow older devices to “run” newer browsers and browser functionality. This in no way modifies your HA install, it just provides a different way to connect to it for devices that can’t load Lovelace. Go read the github page or the dockerhub page for the image as posted above, it provides instructions on how to set it up and use it.

@squirtbrnr apologies for this but I’m clueless about docker, etc. I’m running home assistant (former hassio) and I don’t know how to make this work connecting over ssh to my hassio installation. Could anybody possibly help me?

Someone correct me if I’m wrong, but home assistant (formerly hassio) is running docker underneath in the supervisor. So if you ssh into the supervisor, you can issue a docker run command to get any container running. The docker hub page for the Firefox container has an example of a quick start command.

I tried this, however I get a read only filesystem error and it won’t run. It looks to set up the container (I’m new to docker though so not 100% sure), but doesn’t function.

You probably need to create the folder on the host that the docker run command points to (-v option). Also make sure the user running the docker command (sudo, root, other user, etc) is the same user that has permissions to read/write to that same folder.

I’ve failed to get it working despite trying a number of options around creating new folders, setting chmod and running as Sudo. I figure it’s that the hassio pi install just isn’t designed for this?

So, I went down the route of adding docker to a seperate Fedora box I run, and installed it there… it runs the command, fires up the container and starts the service, then stops the service again instantly.

So I think it’s safe to say this is probably a user error issue somewhere. But very frustrating.

Weird, Docker is usually just an APT command to install and has zero provisions to get working properly. Try installing a new Linux like Ubuntu (works for me :slight_smile:) into a VM and see if Docker finally works right. Go here and see all of the normal and advanced things you can install for Docker (and supervised HassIO) https://github.com/home-assistant/supervised-installer — make sure to install those in the “requirements” section with: sudo apt install app1 app2 etc

@kumar for your first post here, you’re a friggin unicorn… thank you for the awesome workaround! :slight_smile:

Just a brilliant idea! For me this a new hope to use my tablet for the HA.
The problem is I can’t find any similar solution for Pi 4b (ARM7).

Will be thankful for any clue.

This will run on an RPi4. Install docker, download the Firefox image, create the persistent volume with correct permissions, create and run the container with the quick start run command. Read the docker hub page for the image, it explains how to get this running.

@squirtbrnr Could you share more on the exact setup you are using, HA Core or HA, what OS is the host for your docker set up? Have been unsuccessful so far in trying to get it going on a RPi4.

I run HA Core in docker on a Synology DS1515+. Everything I run is in a separate docker container including all HA “add-ons” which are really programs running in containers under the HA supervisor. I’ve never run HA any other way so I have no comment on the RPi4.

As it pertains to the discussion above, Firefox is running in a container. I then use the Safari built-in web browser on the old iPad to connect to the Firefox container. It’s then like using a modern web browser to login to my HA frontend.