Walli Roller Shutter state / position not reported back in Home Assistant

Hello guys,

I think my question is more a generic ZWave question since I am just starting but nevertheless I will explain you what I am experiencing !

I am available if you want logs for each use-cases I am describing below.

So the past two days I fiddled with ZWave to make my first Zwave “network” composed of two nodes

  • (node 1) The Aeotec Z-Stick Gen5 (link)
  • (node 4) A Fibaro Walli Roller Shutter (link)

I finally managed to reach a “usable” state, but I have issue of update / reporting…

With the physical button I can:

  • Fully open the rolling shutter by clicking the up button
  • Fully close the rolling shutter by clicking the down button
  • If I click any button during a movement, I can also stop the rolling shutter at the current position

And in Home Assistant via the services I can:

  • open fully via cover.open_cover
  • close fully via cover.close_cover
  • stop the movement via cover.stop_cover
  • set the rolling shutter at a specific position via cover.set_cover_position

The issue :
Basically, only stopping the cover (Either via physical click or via cover.stop_cover) is updating the position / state back in home assistant…

  • If I open / close fully the shutter (Physically or via home assistant service), the position / state is not updated …
  • If I set a specific position via cover.set_cover_position, the position / state is not updated …

How can I debug this ?
Where do I start ?
I tried to read the OZW_log but I do not understand what is wrong…

Thank you in advance !

This are my OWZ_log when I click on TEST NETWORK in the configuration tab of hassio

2020-01-29 09:08:53.247 Info, Node004, NoOperation::Set - Routing=true
2020-01-29 09:08:53.247 Detail, Node004, Queuing (NoOp) NoOperation_Set (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x00, 0x00, 0x25, 0xb5, 0x73
2020-01-29 09:08:53.247 Detail, 
2020-01-29 09:08:53.248 Info, Node004, Sending (NoOp) message (Callback ID=0xb5, Expected Reply=0x13) - NoOperation_Set (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x00, 0x00, 0x25, 0xb5, 0x73
2020-01-29 09:08:53.258 Detail, Node004,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-01-29 09:08:53.259 Detail, Node004,   ZW_SEND_DATA delivered to Z-Wave stack
2020-01-29 09:08:53.272 Detail, Node004,   Received: 0x01, 0x07, 0x00, 0x13, 0xb5, 0x00, 0x00, 0x02, 0x5c
2020-01-29 09:08:53.273 Detail, Node004,   ZW_SEND_DATA Request with callback ID 0xb5 received (expected 0xb5)
2020-01-29 09:08:53.273 Info, Node004, Request RTT 24 Average Request RTT 57
2020-01-29 09:08:53.273 Detail,   Expected callbackId was received
2020-01-29 09:08:53.273 Detail,   Expected reply was received
2020-01-29 09:08:53.273 Detail,   Message transaction complete
2020-01-29 09:08:53.273 Detail, 
2020-01-29 09:08:53.273 Detail, Node004, Removing current message
2020-01-29 09:08:53.273 Detail, Node004, Notification: Notification - NoOperation

Everything was in the docs.

I enabled polling, with a polling intensity of 1, just on this node and it’s is now working.

I enabled polling because the command classes of my Walli Roller Shutter are including

  • Command Class Association V2
  • Command Class Central Scene V3

as Supported Command Classes and not Controled Command Classes.

Case closed !

Hi @jenova70

How did you manage to get the Walli Roller Shutter fully recognized in HA?
I see the sensor as " FIBARO System Unknown: type=1d01, id=1000"


Do you get the tilt position working as well?
Do you know what the walli cover switch is for?

Thx in advance

Mine is also just recognized as FIBARO System Unknown: type=1d01, id=1000

Would love to know more about how to get this working.

I never enabled polling so far because I worked around creating an automation… Also available as blueprint.
Polling might have the advantage of beeing the also the recomended way by the Fibaro support as far as I read in an other post. I will stick to my workaround which has maybe the advantage of lesser zwave radio activity. Generally speaking I think the root cause is that the Fibaro Devices should do this update by fixing their device firmware and make the update available to the community. Also to those that do not use the Fibaro Home Center :wink: